Не могу установить Z-way на WB

Еще вопрос. При добавлении z-wave устройств, что нужно делать чтобы они попадали в WB?

https://wirenboard.com/wiki/Z-Wave

“После успешного добавления устройство будет видимо в списке “Elements””
Или я неправильно понял вопрос?

После добавлении z-wave устройств к z-way они становятся видны в этом списке, но управлять ими из интерфейса ВБ нельзя (нет движка). Из z-way при этом управлять этими устройствами можно. Что нужно сделать?

Выполните пожалуйста

apt install -y wb-mqtt-zway

Сделал
root@wirenboard-AVV36KSB:~# apt install -y wb-mqtt-zway
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
wb-mqtt-zway : Зависит: libjsoncpp0 но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Хм. Так, подождем с установкой.

service z-way-server restart

выполните пожалуйста.

ничего не происходит

Покажите

ls /opt/z-way-server/automation/userModules

и

ls /opt/z-way-server/automation/userModules/MQTT

root@wirenboard-AVV36KSB:~# ls /opt/z-way-server/automation/userModules
BaseModule MQTT uploadModule.sh
root@wirenboard-AVV36KSB:~# ls /opt/z-way-server/automation/userModules/MQTT
Gruntfile.js htdocs index.js lang lib module.json package.json README.md

Все таки если если ставить по рт по вашей инструкции /dev/ttyUZB то z-way ругается, кроме того на это указывает

Сейчас поставил порт /dev/ttyACM0 и z-way перестал сбрасывать девайсы и выдавать ошибку

А в Devices - устройства появляются?

Они как изначально появились, так и остаются без обновления

Имею в виду основной интерфейс самого контроллера, меню Devices


Для того чтоб там появлялись “новые” устройства - надо перезапустить сервис командой

service z-way-server restart

Я понял, после этой команды ничего не происходит
root@wirenboard-AVV36KSB:~# service z-way-server restart
root@wirenboard-AVV36KSB:~#

А введите

ls /etc/init.d

и

systemctl status z-way-server

root@wirenboard-AVV36KSB:~# ls /etc/init.d
avahi-daemon dnsmasq ntp wb-homa-adc wb-mqtt-mbgate
bluetooth hostapd pppd-dns wb-homa-gpio wb-mqtt-serial
busybox-klogd hwclock.sh procps wb-homa-ism-radio wb-prepare
busybox-syslogd kmod rsync wb-homa-w1 wb-rules
cgmanager mongoose ssh wb-hwconf-manager wb-watch-update
cgproxy netplug udev wb-init wd_keepalive
cron networking watchdog wb-mqtt-confed zbw_connect
dbus nginx wb-gsm-rtc wb-mqtt-db z-way-server
root@wirenboard-AVV36KSB:~# systemctl status z-way-server
● z-way-server.service - LSB: RaZberry Z-Wave service
Loaded: loaded (/etc/init.d/z-way-server; generated; vendor preset: enabled)
Active: active (running) since Tue 2020-07-28 12:51:04 UTC; 6min ago
Docs: man:systemd-sysv-generator(8)
Process: 7461 ExecStop=/etc/init.d/z-way-server stop (code=exited, status=0/SU
Process: 7473 ExecStart=/etc/init.d/z-way-server start (code=exited, status=0/
CGroup: /system.slice/z-way-server.service
└─7476 z-way-server

июл 28 12:51:04 wirenboard-AVV36KSB systemd[1]: Starting LSB: RaZberry Z-Wave se
июл 28 12:51:04 wirenboard-AVV36KSB z-way-server[7473]: Starting z-way-server: d
июл 28 12:51:04 wirenboard-AVV36KSB systemd[1]: Started LSB: RaZberry Z-Wave ser
lines 1-12/12 (END)

Отлично, работает.
Значит перезапуск - командой

systemctl restart z-way-server

root@wirenboard-AVV36KSB:~# systemctl restart z-way-server
root@wirenboard-AVV36KSB:~#

а в z-way появилось такое сообщение
The request failed because the server is not responding

Угу, мы ж его перезапустили, то есть остановили и снова запустили.
У нас есть веб-интерфейс z-way и веб-интерфейс самого контроллера. устройства в z-way (“Elements”) - есть.
А в Devices контроллера - нет, верно?

Да, в в контроллере они исчезли