Apt update error на wb 3.5


#1

Раскопал свой старенький WB 3.5, при apt-get update получаю

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://releases.contactless.ru wheezy Release: The following signatures were invalid: BADSIG E4B0949FAEE07869 Evgeny Boger boger@contactless.ru

Собственно, что делать и встанут ли (и будут работать) новые пакеты на старичка?


#2

Попробуйте явно поставить новый файл ключей:

wget http://releases.contactless.ru.s3-eu-west-1.amazonaws.com/pool/main/c/contactless-keyring/contactless-keyring_0.1_all.deb
dpkg -i contactless-keyring_0.1_all.deb

При использовании apt-get следите, чтобы он не снёс вам полсистемы, всегда внимательно читайте его вопросы.


#3

Не помогло

root@wirenboard:~# wget http://releases.contactless.ru.s3-eu-west-1.amazonaws.com/pool/main/c/contactless-keyring/contactless-keyring_0.1_all.deb
–2017-10-25 21:58:55-- http://releases.contactless.ru.s3-eu-west-1.amazonaws.com/pool/main/c/contactless-keyring/contactless-keyring_0.1_all.deb
Resolving releases.contactless.ru.s3-eu-west-1.amazonaws.com (releases.contactless.ru.s3-eu-west-1.amazonaws.com)… 52.218.49.67
Connecting to releases.contactless.ru.s3-eu-west-1.amazonaws.com (releases.contactless.ru.s3-eu-west-1.amazonaws.com)|52.218.49.67|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 3892 (3.8K) [binary/octet-stream]
Saving to: `contactless-keyring_0.1_all.deb’

100%[=================================================================================================================================================================================================>] 3,892 --.-K/s in 0s

2017-10-25 21:58:56 (12.7 MB/s) - `contactless-keyring_0.1_all.deb’ saved [3892/3892]

root@wirenboard:~# dpkg -i contactless-keyring_0.1_all.deb
Selecting previously unselected package contactless-keyring.
(Reading database … 22757 files and directories currently installed.)
Unpacking contactless-keyring (from contactless-keyring_0.1_all.deb) …
Setting up contactless-keyring (0.1) …
gpg: key B98321F9: “Squeeze Stable Release Key debian-release@lists.debian.org” not changed
gpg: key 473041FA: “Debian Archive Automatic Signing Key (6.0/squeeze) ftpmaster@debian.org” not changed
gpg: key 65FFB764: “Wheezy Stable Release Key debian-release@lists.debian.org” not changed
gpg: key 46925553: “Debian Archive Automatic Signing Key (7.0/wheezy) ftpmaster@debian.org” not changed
gpg: key 518E17E1: “Jessie Stable Release Key debian-release@lists.debian.org” not changed
gpg: key 2B90D010: “Debian Archive Automatic Signing Key (8/jessie) ftpmaster@debian.org” not changed
gpg: key C857C906: “Debian Security Archive Automatic Signing Key (8/jessie) ftpmaster@debian.org” not changed
gpg: Total number processed: 7
gpg: unchanged: 7
root@wirenboard:~# apt-get update
Hit http://ftp.us.debian.org wheezy Release.gpg
Hit http://ftp.us.debian.org wheezy Release
Get:1 http://releases.contactless.ru wheezy Release.gpg [473 B]
Get:2 http://releases.contactless.ru wheezy Release [6936 B]
Err http://releases.contactless.ru wheezy Release

Hit http://ftp.us.debian.org wheezy/main armel Packages
Hit http://ftp.us.debian.org wheezy/main Translation-en
Fetched 474 B in 57s (8 B/s)
Reading package lists… Done
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://releases.contactless.ru wheezy Release: The following signatures were invalid: BADSIG E4B0949FAEE07869 Evgeny Boger boger@contactless.ru

W: Failed to fetch http://releases.contactless.ru/dists/wheezy/Release

W: Some index files failed to download. They have been ignored, or old ones used instead.
root@wirenboard:~# apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages have been kept back:
hostapd libwbmqtt linux-latest mosquitto nginx-common nginx-extras wb-configs wb-homa-adc wb-homa-gpio wb-homa-modbus wb-homa-w1 wb-mqtt-confed wb-mqtt-db wb-mqtt-homeui wb-rules wb-utils
0 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.

ЧЯДНТ?


#4

Раскатайте последний образ для WB35, и обновляйтесь. И нужно прибить вотчдог, чтобы SD карта не сдохла быстро.


#5

а какая связь?

В 3.5 кстати watchdog был только в процессоре, в отличие от следующих моделей.


#6

В последнем образе для WB35 грузится вотчдог который пишет в файл примерно раз в мин и мне кажется он расчитан на eMMC.
Хватило на 4 месяца работы, WB на 30 сек подвисал из-за SD карты - убрал вотчдог - всё сразу заработало нормально на той же карте.


#7

Хм, это странно. Образы для WB35 мы сами не поддерживаем и не тестируем, так что буду признателен, если пришлёте подробности. Запись в файл раз в минуту - это точно не запланированное поведение.

eMMC - это почти то же самое, что SD-карта, только от нормального производителя, с нормальным чипом и по нормальным каналам поставки. Попробуйте купить и поставить индустриальную microSD, сейчас Kingston и SanDisk стали делать недорогие карты.


#8

Как раз и есть карта innoDisk industrial


#9

Починить это относительно просто:
sudo apt-get clean
sudo mv /var/lib/apt/lists /tmp # На всякий случай
sudo apt-get clean
sudo apt-get update


#10

Апгрейд на свежезалитом образе прошел успешно, но цели я не достиг, почти ничего с префиксом wb не обновилось. Собственно, мне бы и со старыми версиями жилось бы хорошо, но вкладки Rules и Virtual Devices не работают.

Лог

root@wirenboard:~# apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages have been kept back:
hostapd libwbmqtt linux-latest mosquitto nginx-common nginx-extras wb-configs wb-homa-adc wb-homa-gpio wb-homa-modbus wb-homa-w1 wb-mqtt-confed wb-mqtt-db wb-mqtt-homeui wb-rules wb-rules-system wb-utils
0 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.
root@wirenboard:~#
root@wirenboard:~# apt-get install hostapd libwbmqtt linux-latest mosquitto nginx-common nginx-extras wb-configs wb-homa-adc wb-homa-gpio wb-homa-modbus wb-homa-w1 wb-mqtt-confed wb-mqtt-db wb-mqtt-homeui wb-rules wb-rules-system wb-utils
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nginx-extras : Depends: perl (>= 5.14.2-21+deb7u4) but 5.14.2-21+deb7u3 is to be installed
Depends: libluajit-5.1-2 but it is not installable
wb-configs : Depends: linux-image-wb
E: Unable to correct problems, you have held broken packages.


#11

Так что, свежие версии wb-* никак не накатить?


#12

поставьте linux-image-wb явно


#13

Добрый день!
Имеется в виду 201610251510_sdcard_32_hynix? И достаточно ли service watchdog stop? или его вообще надо удалить из системы? Просто у меня такая же проблема - виснет WB3.5 без видимых причин, и в messages, и в консоли пусто…


#14

Я прибил логгер, вотчдог, базу данных, правила, управляю всем из openHAB, а WB использую как промежуточный контроллер - пока у WB 2 месяца аптайм.


#15

watchdog ничего не пишет на карточку и на стабильность системы никак влиять не может


#16

хм… тем не менее, в прошлый вторник остановил watchdog, после этого у wb3.5 uptime 5 дней, до тех пор, пока я его не перезагрузил. Это походу рекорд). Продолжаю наблюдение…