End of live Debian “wheezy”


#1

При попытке устнановить пакет, apt-get ругается на ошибку 404.
Судя по всему репозиторий для Debian “wheezy” пирказал долго жить.
Какие репозитории можно юыло бы указать, и ест ьли смысл/возможность обновляться на следующую версию?


#2

Добрый день!

Пожалуйста, попробуйте WB5 rev.9. Не работают репозитории, 404 not found и напишите сюда о результатах.


#3

Не знаю насколько корректно все вышло.
Но ошибка выскакивает в результате окончания поддержки Wheezy и переноса пакетов в архив.
В связи с этим, похоже надо убрать ссылку на репозиторий с апдейтами, и обновить ссылки на репозитории с пакетами в архиве.
Для этого в файле
/etc/apt/sources.list.d/wheezy-backports.list
комментируем ссылку на репозиторий…
В файле
/etc/apt/sources.list
удаляем ссылки на указанные репозитории и вставляем следующие:
deb http://archive.debian.org/debian wheezy main contrib non-free
deb-src http://archive.debian.org/debian wheezy main contrib non-free

apt-get install имя_пакета не должно ругаться после этого…

Если что-то неправильно, поправьте пожалуйста.


#4

Команда, ссылку на которую я давал, как раз приводит /etc/apt/sources.list в правильный вид


#5

apt-get update
apt-get install wb-configs

Выполнение этих команд ничего не дает.
Результат первой выдает сообщения такого вида:
W: Failed to fetch http://http.debian.net/debian/dists/wheezy-backports/main/binary-armel/Packages 404 Not Found [IP: 151.101.244.204 80]

А результат второй команды:
root@wirenboard:~# apt-get install wb-config
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package wb-config
root@wirenboard:~#

Естественно перед выполнением команд вернул состояние репозиториев до вчерашнего состояние.


#6

Чтобы обновить wb-configs, достаточно, чтобы обновился только наш репозиторий. Старые репозитории Debian, из-за которых случилась проблема, и не должны отвечать.
Пришлите полный вывод, пожалуйста.


#7

root@wirenboard:/# apt-get update
Hit http://archive.debian.org wheezy Release.gpg
Hit http://archive.debian.org wheezy Release
Hit http://releases.contactless.ru wheezy Release.gpg
Ign http://http.debian.net wheezy-backports Release.gpg
Hit http://releases.contactless.ru wheezy Release
Ign http://http.debian.net wheezy-backports Release
Ign http://security.debian.org wheezy/updates Release.gpg
Ign http://security.debian.org wheezy/updates Release
Err http://http.debian.net wheezy-backports/main armel Packages

Err http://http.debian.net wheezy-backports/main armel Packages

Err http://http.debian.net wheezy-backports/main armel Packages

Err http://http.debian.net wheezy-backports/main armel Packages
404 Not Found [IP: 151.101.244.204 80]
Ign http://http.debian.net wheezy-backports/main Translation-en
Hit http://archive.debian.org wheezy/main Translation-en
Hit http://archive.debian.org wheezy/main Sources
Hit http://archive.debian.org wheezy/main armel Packages
Hit http://releases.contactless.ru wheezy/main all Packages
Hit http://releases.contactless.ru wheezy/main armel Packages
Err http://security.debian.org wheezy/updates/main Sources
404 Not Found [IP: 151.101.244.204 80]
Err http://security.debian.org wheezy/updates/contrib Sources
404 Not Found [IP: 151.101.244.204 80]
Err http://security.debian.org wheezy/updates/main armel Packages
404 Not Found [IP: 151.101.244.204 80]
Err http://security.debian.org wheezy/updates/contrib armel Packages
404 Not Found [IP: 151.101.244.204 80]
Ign http://releases.contactless.ru wheezy/main Translation-en
Ign http://security.debian.org wheezy/updates/contrib Translation-en
Ign http://security.debian.org wheezy/updates/main Translation-en
W: Failed to fetch http://http.debian.net/debian/dists/wheezy-backports/main/binary-armel/Packages 404 Not Found [IP: 151.101.244.204 80]

W: Failed to fetch http://security.debian.org/dists/wheezy/updates/main/source/Sources 404 Not Found [IP: 151.101.244.204 80]

W: Failed to fetch http://security.debian.org/dists/wheezy/updates/contrib/source/Sources 404 Not Found [IP: 151.101.244.204 80]

W: Failed to fetch http://security.debian.org/dists/wheezy/updates/main/binary-armel/Packages 404 Not Found [IP: 151.101.244.204 80]

W: Failed to fetch http://security.debian.org/dists/wheezy/updates/contrib/binary-armel/Packages 404 Not Found [IP: 151.101.244.204 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

root@wirenboard:/# apt-get install wb-config
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package wb-config


#8

s на конце забыли


#9

root@wirenboard:/# apt-get install wb-configs
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
liblog4cpp5 libwbmqtt0 libwebsockets6 mqtt-tools wb-mqtt-db
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
jq libwbmqtt0 linux-firmware-image-4.9.22-wb2 linux-image-4.9.22-wb2
linux-image-wb2 python-six python-wb-common u-boot-tools-wb watchdog
wb-configs-wheezy wb-utils
The following packages will be REMOVED:
linux-image-4.1.15-imxv5-x0.1 u-boot-tools wb-homa-ism-radio wb-mqtt-homeui
wb-mqtt-serial wb-rules-system
The following NEW packages will be installed:
jq libwbmqtt0 linux-firmware-image-4.9.22-wb2 linux-image-4.9.22-wb2
linux-image-wb2 python-six u-boot-tools-wb wb-configs-wheezy
The following packages will be upgraded:
python-wb-common watchdog wb-configs wb-utils
4 upgraded, 8 newly installed, 6 to remove and 24 not upgraded.
Need to get 11.5 MB of archives.
After this operation, 12.8 MB of additional disk space will be used.
Do you want to continue [Y/n]? y

Удалено…

Действительно… Куча нецензурных слов в сторону моей “внимательности”…
Забыл s
Фиксится двумя командами…

apt-get update
apt-get install wb-configs


#10

Там ещё из-за зависимостей, видимо, удалилось лишнее.
Поэтому выполните ещё
apt install wb-mqtt-homeui wb-mqtt-serial wb-rules-system


#11

Спасибо за наводку.
Очень помогло.

А данные изменения будут внесены в образ флешки для WB4?
А то после восстановления очень мучительны шаги по поиску инфы…

NB!!
apt-get update
apt-get install wb-configs
apt-get install wb-mqtt-homeui wb-mqtt-serial wb-rules-system


#12

Нет, мы уже не поддерживаем WB4.

Я как-то не сразу заметил, что у вас WB4. Для вас самым простым способом будет такой: Не получается установить пакет zabbix-agent (похоже, вы так вначале и делали, а я вас сбил).


Виснет wb-mqtt-serial