Отключение устройств RS485


#1

Добрый день.
подскажите пожалуйста в решении вопроса.
имею несколько устройст на одной шине RS485. стабильно работают до перезагрузки, после которой остается только одно которое было добавлено первым, а остальные приходится опять добавлять через config.


#2

Добрый день, mpnnic!
Можно попросить вас ghbkfnm dsdjl rjvfyls
ls -la /etc/wb-mqtt-serial.conf
Кажется, вы затерли симлинк


#3

к сожалению в данный момент нет возможности (не дома)
как только смогу приложу вывод команды


#4

добрый день
можете помочь с проблемой
выполнил команду по вашему совету:
root@wirenboard-ADUU7HGQ:~# ls -la /etc/wb-mqtt-serial.conf
lrwxrwxrwx 1 root root 33 Nov 3 2016 /etc/wb-mqtt-serial.conf -> /mnt/data/etc/wb-mqtt-serial.conf


#5

mpnnic, добрый день! Скажите, вы добавляете устройства кнопкой “+Serial Device”:


В интерфейсе подключения устройств должны отображаться все устройства.
Поведение, которое вы описываете, похоже на то, как если бы вы вбивали настройки каждого нового устройства поверх существующих.


#6

добавляю через “+Serial Device”
не совсем понял как можно добавлять по верх существующих?
добавляю 2 устройства - сохранение перезагрузка- остается только одно


#7

А какое из устройств остается? Первое добавленное, последнее добавленное? Пришлите скриншоты после сохранения до перезагрузки и после, пожалуйста.


#8

остается первое добавленное


#9

добавил одно устройство


-сохранил и перезагрузил


#10

добрый день
есть ли решение данной проблемы ?
помогите пожалуйста


#11

дополнительно:
поменял устройства в списке - поставил счетчик MAP3E первым а MSW вторым.
после перезагрузки остался только MSW


#12

удалил все устройства
перезагрузил
отключил все устройства физически за исключением MAP3E
перезагрузил
в списке опять только MSW


#13

Я бы голову не ломал, а сделал FACTORYreset. Такой ситуации не воспроизвести, а стало быть советовать что-то трудно.
По всей видимости что-то “настроили” не то, и забыли.


#14

спасибо
после неоднократных попыток сделал factoryreset
все заработало


#15

Спасибо, @Flagman что подсказали решение! Интересно было бы понять, что же именно произошло, случай редкий.


#16

добрый день
в том то и дело что из коробки
ничего с контроллером не делал
только добавил устройства


#17

Серийник контроллера пришлите, пожалуйста


#18

добрый вечер
ADUU7HGQ


#19

а что это конкретно значит? Вы контроллер отключаете от питания и подаёте заново?


#20

через вебинтерфейс или через putty