Сброс пароля через подключение с MacOs (не отправляются сигналы с клавиатуры)

Добрый день!
Пытаюсь сбросить пароль на WirenBoard-7 подключаясь к Debug Console из MacOs (11.6 Big Sur)
https://wirenboard.com/wiki/Debug_Console
https://wirenboard.com/wiki/WB6_root_password_recovery

Последовательность шагов:

  1. отключаю контроллер от сети
  2. подключаю usb к компьютеру
  3. в терминале макоси ввожу
sudo cu -s 115200 -l /dev/tty.usbserial-1410

Что происходит:

  1. происходит загрузка, в тч вижу сообщение “hit key …” в теч 1сек, но на нажатие пробела загрузка идет дальше
  2. после окончания загрузки приглашение на ввод логина, но никакие команды с клавиатуры не передаются

Такое ощущение, что сигналы с клавиатуры не доходят до контроллера.

Помогите пожалуйста, куда копать дальше

Лог с экрана: dskut@dskut-x:~$ sudo cu -s 115200 -l /dev/tty.usbmodemWB71 Connected.U-Bo - Pastebin.com

Добрый день.
Судя по логам, всё загружается штатно.
Попробуйте использовать альтернативный терминал для MacOS?

Есть какой-то проверенный, на котором точно работает подключение нормально?

Использую minicom, на нем работает точно. Не знаю, есть ли для MacOS.
А работает отправка символов уже после загрузки контроллера?

Нет, тоже не работает. Например, после ввода логина + ENTER ничего не происходит, на ctrl + c|z|d никакой реакции итд

Добрый день?
Удалось вам победить проблему самостоятельно?
Пробовали ли с другой операционной системы подключаться?
Довольно штатная операция, от ПО контроллера зависеть не должна.

Добрый день! Еще пока не удалось попробовать с другими терминалами/ОС
Когда попробую, напишу сюда

1 Like

Пробовал с Макоси через iTerm2 - симптомы те же, не отправляются сигналы с клавиатуры. Подозреваю, что дело в настройках Макоси.
В итоге решил свою задачу тем, что подключился с другого компа с Windows10 через MobaXterm.

2 Likes