Add new device template


#1

Hi,

we got a new WB6 and i need to connect it with nedap mace mm (qr) reader thought rs485, the device is not available in the device list, how can i add a template for the device? what is the required parameters i need to get from the device ?

please find the device datasheet and installation manuall for reference

thank you,


#2

Hi!
Do you have detailed info about this device communication abilities?
There is no info in datasheet and installation manuall about Modbus registers.
On web site I didn’t found this info too.
Please request Modbus registers table if it possible. This document will solve your problem much easier


#3

Hello ramymabrouk,
as far as I understand their documentation this reader could be connected via RS-485 but does not support the Modbus protocol.

If my assumption is correct you will (probably) have to write some script to communicate with the reader and leave one of the controller RS-485 ports free to communicate with it.

Templates are intended to be used with Modbus devices only.


назначил(а) ответственного EvgenyBoger #4

#5

Hi @Kilpio,
can you please explain this more


#6

I meant approximately this: if the reader device supports it’s own set of messages and commands (not the Modus ones) than you have to write your own piece of code implementing the communication protocol of the reader to get data from and set commands to it. You have to find info on this protocol somewhere, though.

If your controller communicates with some Modbus devices connected to it, the Modbus driver (wb-mqtt-serial) occupies one of the serial RS-485 ports (or even both ports). So you need to connec
t the reader to the ‘unoccupied’ port, set the correct communication parameters and run your software.

If the QR-reader is the only device connected — just don’t care but stop the wb-mqtt-serial driver.


#7

after reading thr datasheet again i found that it supports CR/LF, OSDP protocols, while the OSDP needs special firmware upgrade we should use the CR/LF.

the typical setup will be 2 Mace readers on turnstile, so i need 2 RD-485 and 2 relay modules for both turnstile directions, please correct me if something wrong.


#8

I see, so you need one RS-485 port to communicate with relays. I can not uderstand definetly if you can connect two readers in parallel to one port. So may be you need three RS-485 ports in total. You can purchase theadditional RS-485 modue for the Wien Board 6 controller, though.
Do you consider to connect the readers to the controller’s USB ports? I think it is also possible?


#9

the reader does not has USB interface,


#10

Hi Ramy,

“CR/LF” is not a protocol, it only implies that the protocol is text-based.

The protocol itself is described in document titled “MACE Firmware Guide”. Unfortunately I couldn’t find it in the internet, so please request it through your Nedap dealer.

What I indeed managed to find in Google is the firmware guide for another Nedap reader: ftp://ftp.impro.net/Firmware/3rd%20Party/NEDAP/uPASS/uPASS_FirmwareGuide_E.pdf

As you can see, according to the manual, reader sends text strings whenever a tag is read:
image

As my colleague mentioned earlier, you will need to write a simple script or program which listens to the RS-485 ports for these messages and process them according to your task.


#11

Hi Evgeny,
thanks for the explaination, i have added the Mace firmware guide to the google drive folder, as i understand i need to shutdown the RS-485 service on the board and open it directly from my code and handle the required events , if i am correct please tell me how to shut it down permanently? and if i can just pyserial for communication with the port?


#12

Please open web interface, then configs, then Serial Device Configuration. There will be list of ports controlled by the built-in wb-mqtt-serial service. Uncheck “enable” for the one you would like to access from your code and click “save”. The same could be done by manually editing configuration file /etc/wb-mqtt-serial.conf

You can also completely remove wb-mqtt-serial service if you don’t plan to use it:

apt remove wb-mqtt-serial

yes