Ошибка apt-get update на wb-2207

Попытался сделать всё по инструкции Wiren Board 7: Errata — Wiren Board. apt update не работал, поэтому вручную привел файлы к виду:
debian-upstream.list
deb http://archive.debian.org/debian/ stretch main
deb http://archive.debian.org/debian-security/ stretch/updates main
stretch-backports.list
deb http://archive.debian.org/debian stretch-backports main
Снова не помогло, после этого ошибка
log.txt (5,3 КБ)
Архив
diag_ACSV3HN6_2024-01-22-17.28.24.zip (370,4 КБ)
Подскажите пожалуйста, что можно сделать?

Добрый день.
А какие ключи GPG сейчас существуют?
Посмотрите на вывод

apt-key list

и проверьте - валидны ли существующие.
Путь проще - установить все ж как и рекомендовано пакет wb-configs

apt-get --allow-unauthenticated install wb-configs

Затем обновить список пакетов.

Если бы все работало как рекомендовано, не обращался бы за помощью.

root@wirenboard-ACSV3HN6:~# apt-get --allow-unauthenticated install wb-configs
Reading package lists… Done
Building dependency tree
Reading state information… Done
wb-configs is already the newest version (2.3.4-wb101).
The following packages were automatically installed and are no longer required:
libatomic1 liblua5.1-0 lua-bitop lua-cjson
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
apt update после этого с той же ошибкой.

Вывод apt-key list:
log.txt (4,5 КБ)
Подскажите пожалуйста, что можно ещё сделать?

Актуален 2.3.4-wb103 для stretch.
Вывод apt policy wb-configs?
Ну и обновите списки,

apt --allow-unauthenticated update

Нормальные.
Время на контроллере верное?

log.txt (4,9 КБ)
Время верное

Меня смущает сильно наоличие в выводе

Couldn't create temporary file /tmp/apt.conf.46GpGU for passing config to apt-key

Провертие пожалуйста права на каталог /tmp, попробуйте создать в нем какой-либо файл, ну и покажите что сейчас в этом каталоге.
Ну или дайте ssh на контроллер - проверю сам.

log.txt (4,8 КБ)
Файл непустой, создался без проблем

chmod 1777 /tmp && ls -l /tmp

что возвращает?
Ну и попробуйте списки обновить еще раз.

root@wirenboard-ACSV3HN6:/tmp# chmod 1777 /tmp && ls -l /tmp
lrwxrwxrwx 1 root root 13 Mar 6 2023 /tmp → /mnt/data/tm

Обновил списки apt install wb-configs , 3 раза apt update; apt upgrade и всё заработало. Спасибо!!!
Единственное, при update есть ошибка

root@wirenboard-ACSV3HN6:/tmp# apt update
Ign:1 Index of /debian stretch InRelease
Hit:2 Index of /debian-security stretch/updates InRelease
Hit:3 Index of /debian stretch-backports InRelease
Hit:4 http://deb.wirenboard.com/wb7/stretch stable InRelease
Get:5 Index of /debian stretch Release [118 kB]
Get:6 Index of /debian stretch Release.gpg [3,177 B]
Hit:7 Index of /debian stretch/main armhf Packages
Ign:7 Index of /debian stretch/main armhf Packages
Hit:8 Index of /debian stretch/main Translation-en
Ign:8 Index of /debian stretch/main Translation-en
Hit:7 Index of /debian stretch/main armhf Packages
Ign:7 Index of /debian stretch/main armhf Packages
Hit:8 Index of /debian stretch/main Translation-en
Ign:8 Index of /debian stretch/main Translation-en
Ign:7 Index of /debian stretch/main armhf Packages
Err:8 Index of /debian stretch/main Translation-en
BZ2_bzread: /var/lib/apt/lists/partial/archive.debian.org_debian_dists_stretch_main_i18n_Translation-en.bz2 Read error (-5: DATA_ERROR_MAGIC)
Ign:7 Index of /debian stretch/main armhf Packages
Fetched 3,177 B in 12s (251 B/s)
Reading package lists… Done
E: Failed to fetch http://archive.debian.org/debian/dists/stretch/main/i18n/Translation-en BZ2_bzread: /var/lib/apt/lists/partial/archive.debian.org_debian_dists_stretch_main_i18n_Translation-en.bz2 Read error (-5: DATA_ERROR_MAGIC)
E: Some index files failed to download. They have been ignored, or old ones used instead.

Ну вот… У вас это вообще симлинк в шестой раздел.
Может еще где-то всплыть.

Я б сделал apt clean ну и проверил права на сам файл. В общем можно и удалить его попробовать.

log.txt (6,7 КБ)
apt clean не помог, удаление не помогло

Очень непродуктивно когда вы отправляете мне просто вывод команд.
В контроллере - самый обыкновенный Debian, точно такой же как и на компьютере. Для работы с ним все ж требуется знать основы.
Как я вижу архитектура каталогов была изменена, о чем говорит уже замена /tmp симлинком в раздел смонтированный в /mnt.
Я не могу догадаться что еще в контроллере изменено и перенастроено. Так что - посмотрите пожалуйста на права на файлы. Запустите обновление с отладчиком, например.
Но оптимальный способ - поднять документацию по которой эта инсталляция настраивалась и проверить - что еще изменено.

Понял вас, буду разбираться.
На другом контроллере появилась такая же проблема, wb-configs не обновлялся, ничего не помогало. Сразу привел файлы к виду
debian-upstream.list
deb http://archive.debian.org/debian/ stretch main
deb http://archive.debian.org/debian-security/ stretch/updates main
stretch-backports.list
deb http://archive.debian.org/debian stretch-backports main
После этого
chmod 1777 /tmp && ls -l /tmp
И все запустилось без проблем.
Спасибо за помощь!

1 Like