Энергомера CE303 S31 WB-MIO-E v2

Добрый день. Подскажите совместима ли такая конфигурация? Подключил счетчик напрямую к ВБ все отлично работает… через WB-MIO-E нет. Куда копать что смотреть?


Добрый день. Модуль WB-MIO-E v2 предназначен для удалённого подключения устройств WBIO (модули ввода-вывода) по протоколу Modbus по шине RS-485 и/или Ethernet (протоколы Modbus TCP и Modbus RTU over TCP). Через него точно не получится подключить ваш счетчик. Может вы имеете в виду подключение через WB-MGE v.2?

Нет пробовал именно такой модуль. Видимо не вник… WB-MGE v.2 может решить такую задачу? Но по описаниям и настройка внутри это совершенно одинаковые железки… только у MIO-E есть интерфейс WBIO.

Из описания: WB-MIO-E — это два отдельных устройства WB-MIO и WB-MGE v.2 в одном корпусе с общей шиной RS-485

Соотвественно логично предположить и ожидать что если мы не используем (да и если используем) порт IO то подключив к RS485 устройство мы получим тот же эффект если бы подключили на локальный порт тем более что в настройках сериал устройств есть modbus/tcp а есть передача пакетов через TCP что и выбрано… предполагая прозрачную передачу пакетов. Задача стоит удаленно опросить счетчики энергомера, РиМ с DLMS/Coseum получить данные на WB в mqtt

Да, тут вы правы. А при подключении к контроллеру напрямую какие настройки порта использовались?
Обратите внимание - у счетчика один стопбит. Проверьте и настройте так же. Ну и MIO часть - тоже.
И еще - работать будет только в режиме Modbus over tcp. Как сейчас настроено, не надо переключать в Modbus TCP.

ну вот есть сомнения в том какой протокол ходит между энергомерой и ВБ когда энергомера подключена напряму… если там реально модбас то сейчас хочу немного подругому попробовать через socat создал порт виртуальный rs485 сейчас обновлюсь и хочу попробовать его использовать для подключения энергомеры

Не модбас.
Вот тут указано

  "protocol" : "energomera_iec",

То есть надо считать и формировать посылки самостостоятельно.
socat - это как раз и есть Modbus over TCP. Настроить шину 485 на MIO надо правильно.

а что там можно настроить? в вебе там особо не разгуляешься… с сокатом да не вышло…

Настройки параметров порта. Стопбиты - установить по параметрам счетчика.

все сделано. в вебе Настроил так же как настраивал порт локальный на ВБ когда получил нормальное соединение со счетчиком. По каким-то не известным причинам счетчик не работает через мой MIO-E v2. Судя по форуму и ответу людей все по идеи должно работать. Куда копать? выставил 7e1 все равно не работает. Прошу помочь решить проблему.