Горит зеленая лампочка, не загружается контроллер


#1

Здравствуйте!
Горит зеленая лампочка на контроллере, сразу же после подачи питания, горит примерно в течении 15 секунд, затем на секунду гаснет и так по кругу.
Возможно контроллер повредили в результате не корректного подключения.
Восстановление прошивки не получаться сделать, так как контроллер не входит в режим восстановления.
Возможно ли, и каким образом оживить контроллер?


#2

Ну для начала подключитесь к uart и посмотрите что он там показывает.


#3

А расскажите что делали?

Опять же, нужно максимум подробностей.


#4

Оборудование в щите переподключали, предположительно задели фазу 220В проводом GND датчика температуры 1-wire, остальные провода датчика были подключены в контроллер.


#5

Достаточно вероятно, что вы повредили контроллер. Пожалуйста, подключитесь к отладочному разъёму, и посмотрите, что контроллер туда выводит


#6

Как подключиться и посмотреть, через какое ПО?


#7

Нужно сделать по инструкции: http://contactless.ru/wiki/index.php/Debug_UART
Как именно выглядит отладочный порт, зависит от версии контроллера. Если вы работает под Windows, то удобнее всего работать через программу PuTTY. Подробнее в статье в вики.

Обычно, если контроллер не полностью сгорел, какие-то символы в отладочный порт всё-таки должны выводиться.


#8

Подключился, никаких символов не выводиться, при перезагрузке в putty курсор перескакивает на новую строчку.


#9

Сейчас остаётся два варианта: либо как-то неправильно подключён отладочный порт (физическое подключение, настройки PuTTY), либо контроллер действительно повреждён и возможности удалённой диагностики исчерпаны.
Во втором случае напишите, пожалуйста, на info@contactless.ru, чтобы обсудить условия ремонта/покупки нового. В письмо вставьте ссылку на этот топик.


#10

добрый день, такая же в точности проблема, как победили и что мне делать? wb5, после того как крышку переднюю снаял, что бы глянуть заражается ли батарея, контроллер так стал себя вести.


#11

Добрый день, avl417!
И в отладочной консоли у вас тоже ничего не показывается? Настройки последовательного порта в терминале порта 115200 8N1?
Можете еще раз снять крышку и убедиться, что все провода целы и соединения не нарушены?


#12

Здравствуйте, помогите пожалуйста вернуть к жизни устройство Wiren Board NETMON-1. Тоже, после подачи питания светится зелёный индикатор примерно 15 секунд, затем гаснет на 2 секунды и всё повторяется бесконечно.
Подключил его к ноутбуку через UART, вижу что идёт процесс загрузки (ну или что это?, не знаю), доходит каждый раз до определённой места и начинается заново. Что мне делать? Спасибо.


#13

Владимир, добрый день!
Вероятно, проблемы с процессорной платой и мы, может быть, сможем найти pgvyue/ Можете пока прислать вывод отладочной консоли?


#14

Здравствуйте. Вот так было.


#15

Это может быть ещё проблема с SD-картой. Если не поможет поменять, то тогда менять процессорную плату.


#16

Всем здравствуйте. Пока ждал ответов немного поэкспериментировал, позвольте мне рассказать что у меня получилось. Заранее хочу сказать что с настройкой подобных устройств никогда не сталкивался и линукс вижу впервые. Пожалуйста сильно не ругайтесь, если от меня будет много глупых вопросов.
У меня под рукой имеется второй такой-же контролёр, я установил с него флешку и устройство загрузилось. Тогда я сделал следующее. Взял другую SD карту и по инструкции записал на неё сначала вот этот образ флешки с сайта: 201606281425_sdcard_netmon1_alliance.img.zip затем этот: 201606281425_sdcard_netmon1_hynix.img.zip. Делал из Windows по инструкции, но устройство ни с тем ни с другим не загрузилось. Отсюда сразу вопрос: какой образ подойдёт моему контролёру, и какой минимальный объем SD карты должен быть?
Затем я на всякий случай сделал образ родной SD карты с помощью программы Clonezilla, загрузившись на ноутбуке с Live CD с линукс, и ещё скопировал всё содержимое карты себе на диск D. Далее, я удалил все файлы и папки с проблемной флешки и скопировал всё с флешки рабочего контролёра. И он тоже запустился. Только с IP адресом того контроллера, с которого копировал. Пароля, чтобы сменить адрес никто не знает, я даже не знаю кто их настраивал. Нам они пришли уже настроенные. Тогда я начал переносить по несколько штук назад родные папки, пока контролёр не пинганулся по родному IP. Отсюда второй вопрос: возможно ли изменить IP адреса устройству не командами а отредактировав некий файл хранящиеся на карте?
Ну и наконец самое главное и важное. Если у меня получится записать на родную флешку правильный образ с вашего сайта и настроить нужный IP адрес. Можно будет перенести оригинальные файлы и папки нужные для работы заббикса? Я сам не смогу просто это настроить, а это единственное что у нас используется. Контролёр стоит в необслуживаемом контейнере и мы смотрим удалённо температуру и влажность с его внутреннего датчика в заббиксе.
Вот такая ситуация у меня, заранее спасибо всем за любую помощь.


#17

Владимир, добрый день! Позволил себе выделить ключевые моменты в тексте вашего сообщения.
У меня нет под рукой устройства, с которым я бы помог бы помочь вам точно указать нужные шаги по восстановлению.

На самом деле вся нужная вам информация хранится в двух файлах:
/etc/network/instarfaces – в нем задан IP-адрес,
и /etc/shadow — в нем хранится захешированный пароль рута.

Поменяйте адрес интерфейса на нужный вам,
а чтобы сбросить пароль на пароль по умолчанию, wirenboard,
перепишите запись рута в /etc/shadow на
root:$6$u8qrkBFz$AI3Lgts8YHgR46cTDFf4eWi/Foky8Qy2frQjr3LGpcPDvkOUbzuF8TQxz3rR8apMykFkgXIgkT2CFQbOTJ50v/:16912:0:99999:7:::

Если что-то не получается, обращайтесь.


#18

Спасибо, завтра буду разбираться, сегодня у меня заканчивается рабочий день. Но всё-же какой образ мне скачать для моей железки? Может фото сюда загрузить? Она похожа на NETMON-1 по фото с вашего сайта, но может мне другой файл нужно качать? Или флешка на которую я записываю не подходит? 1Gb объём.


#19

Объем достаточный, вряд ли в нем проблема. Интересен модуль памяти, какой установлен. можете сфотографировать?


#20


Вы про эту микросхему говорите?