После обновления WB5 с 201802052055 до wb-2204 пустые страницы в WEB интерфейсе

Здравствуйте. Дошли руки обновить древнюю версию. Обновил через Linux без проблем. Однако в WEB интерфейсе все страницы пустые, кроме “Devices”.




Что можно сделать?

Здравствуйте!
Правильно ли я понимаю, что обновили контроллер с помощью

apt update && apt upgrade

Возможно, что не правильно прописаны репозитории для обновления. Пришлите, пожалуйста, файл

/etc/apt/sources.list.d/wirenboard.list

Меняли ли в нем что-то самостоятельно или добавляли ли в директорию дополнительные файлы с адресами репозиториев?

Изначально сделал “Восстановление прошивки” через ПК с ОС Linux по инструкции и получил такой результат. Потом сделал “apt update && apt upgrade” - без изменений.

root@wirenboard-AZVUEFY7:~# cat /etc/apt/sources.list.d/wirenboard.list                            # This file is automatically generated by wb-release.
# DO NOT EDIT THIS FILE!
#
# If you want to switch to testing, use command
#   wb-release -t testing
deb http://deb.wirenboard.com/wb5/stretch stable 

Выложите пожалуйста версии пакетов, резултат apt policy wb* сверю версии пакетов.

root@wirenboard-AZVUEFY7:~# apt policy wb*
wb-mqtt-confed:
  Installed: 1.2.2
  Candidate: 1.2.2
  Version table:
 *** 1.2.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wbrazilian:
  Installed: (none)
  Candidate: 3.0~beta4-19
  Version table:
     3.0~beta4-19 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-mqtt-apcsnmp:
  Installed: (none)
  Candidate: 0.2
  Version table:
     0.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-homa-zway:
  Installed: (none)
  Candidate: 1.0.3+wb2
  Version table:
     1.0.3+wb2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-homa-adc:
  Installed: 1.14.6
  Candidate: 1.14.6
  Version table:
 *** 1.14.6 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-homa-rfsniffer:
  Installed: (none)
  Candidate: 1.0.9
  Version table:
     1.0.9 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-homa-modbus:
  Installed: (none)
  Candidate: (none)
  Version table:
wbritish-small:
  Installed: (none)
  Candidate: 7.1-1
  Version table:
     7.1-1 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-mqtt-spl-meter:
  Installed: (none)
  Candidate: 1.1.1
  Version table:
     1.1.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-suite:
  Installed: 1.0
  Candidate: 1.0
  Version table:
 *** 1.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-dt-overlays:
  Installed: 1.5.0
  Candidate: 1.5.0
  Version table:
 *** 1.5.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-knxd-config:
  Installed: 1.1.1
  Candidate: 1.1.1
  Version table:
 *** 1.1.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-homa-webinterface:
  Installed: (none)
  Candidate: (none)
  Version table:
wb-mqtt-lirc:
  Installed: (none)
  Candidate: 1.1.4
  Version table:
     1.1.4 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-metrics:
  Installed: (none)
  Candidate: 0.1.1
  Version table:
     0.1.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-sht1x:
  Installed: (none)
  Candidate: 1.0
  Version table:
     1.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-configs:
  Installed: 2.3.3
  Candidate: 2.3.3
  Version table:
 *** 2.3.3 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-db:
  Installed: 1.7.3
  Candidate: 1.7.3
  Version table:
 *** 1.7.3 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-snmp:
  Installed: (none)
  Candidate: 1.0.1
  Version table:
     1.0.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-w1:
  Installed: (none)
  Candidate: (none)
  Version table:
wbritish-huge:
  Installed: (none)
  Candidate: 7.1-1
  Version table:
     7.1-1 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-daemon-watchdogs:
  Installed: (none)
  Candidate: 1.1
  Version table:
     1.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-db-cli:
  Installed: 1.2.1
  Candidate: 1.2.1
  Version table:
 *** 1.2.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-bmp085:
  Installed: (none)
  Candidate: 1.2
  Version table:
     1.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-utils:
  Installed: 3.5.0
  Candidate: 3.5.0
  Version table:
 *** 3.5.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-diag-collect:
  Installed: (none)
  Candidate: 1.2.0
  Version table:
     1.2.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wbritish-insane:
  Installed: (none)
  Candidate: 7.1-1
  Version table:
     7.1-1 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wbar-config:
  Installed: (none)
  Candidate: 2.3.4-6
  Version table:
     2.3.4-6 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-homa-gpio:
  Installed: 1.19.5
  Candidate: 1.19.5
  Version table:
 *** 1.19.5 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-timestamper:
  Installed: (none)
  Candidate: 1.10.1
  Version table:
     1.10.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-mhz19:
  Installed: (none)
  Candidate: 1.0
  Version table:
     1.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-zway:
  Installed: (none)
  Candidate: 1.0.3+wb2
  Version table:
     1.0.3+wb2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-co2mon:
  Installed: (none)
  Candidate: 1.1.1
  Version table:
     1.1.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-test-suite-dummy:
  Installed: (none)
  Candidate: 1.9.0
  Version table:
     1.9.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-update-manager:
  Installed: 1.2.5
  Candidate: 1.2.5
  Version table:
 *** 1.2.5 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wbritish:
  Installed: (none)
  Candidate: 7.1-1
  Version table:
     7.1-1 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-adc-tools-mxs:
  Installed: 1.0
  Candidate: 1.0
  Version table:
 *** 1.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wbritish-large:
  Installed: (none)
  Candidate: 7.1-1
  Version table:
     7.1-1 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-mqtt-smartbus:
  Installed: (none)
  Candidate: 1.2
  Version table:
     1.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-zabbix:
  Installed: (none)
  Candidate: 0.2
  Version table:
     0.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-homa-w1:
  Installed: 1.10.1
  Candidate: 1.10.1
  Version table:
 *** 1.10.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wbar:
  Installed: (none)
  Candidate: 2.3.4-6
  Version table:
     2.3.4-6 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-homa-ism-radio:
  Installed: 1.17.3
  Candidate: 1.17.3
  Version table:
 *** 1.17.3 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wbox:
  Installed: (none)
  Candidate: 5-1+b2
  Version table:
     5-1+b2 500
        500 http://deb.debian.org/debian stretch/main armel Packages
wb-mqtt-serial:
  Installed: 1.63.0
  Candidate: 1.63.0
  Version table:
 *** 1.63.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-rules:
  Installed: 1.7.1
  Candidate: 1.7.1
  Version table:
 *** 1.7.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-adc:
  Installed: (none)
  Candidate: (none)
  Version table:
wb-essential:
  Installed: 1.5.0
  Candidate: 1.5.0
  Version table:
 *** 1.5.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-rules-system:
  Installed: 1.8.0
  Candidate: 1.8.0
  Version table:
 *** 1.8.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-release-info:
  Installed: 1.0-stable~wb5+stretch~20220524080811
  Candidate: 1.0-stable~wb5+stretch~20220524080811
  Version table:
 *** 1.0-stable~wb5+stretch~20220524080811 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-hwconf-manager:
  Installed: 1.42.1+really1.41.2
  Candidate: 1.42.1+really1.41.2
  Version table:
 *** 1.42.1+really1.41.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-mbgate:
  Installed: 0.1.4
  Candidate: 0.1.4
  Version table:
 *** 0.1.4 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-gpio:
  Installed: (none)
  Candidate: (none)
  Version table:
wb-mcu-fw-flasher:
  Installed: 1.0.8
  Candidate: 1.0.8
  Version table:
 *** 1.0.8 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mqtt-dac:
  Installed: 1.1.2
  Candidate: 1.1.2
  Version table:
 *** 1.1.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-homa-ninja-bridge:
  Installed: (none)
  Candidate: 1.9.1
  Version table:
     1.9.1 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-homeui:
  Installed: 2.5.7
  Candidate: 2.5.7
  Version table:
 *** 2.5.7 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-zigbee2mqtt:
  Installed: (none)
  Candidate: 1.1.0
  Version table:
     1.1.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-configs-wheezy:
  Installed: (none)
  Candidate: (none)
  Version table:
wb-configs-stretch:
  Installed: 2.3.3
  Candidate: 2.3.3
  Version table:
 *** 2.3.3 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mcu-fw-updater:
  Installed: 1.3.0
  Candidate: 1.3.0
  Version table:
 *** 1.3.0 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-test-suite:
  Installed: 1.20
  Candidate: 1.20
  Version table:
 *** 1.20 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wb-mb-explorer:
  Installed: (none)
  Candidate: 1.2.7
  Version table:
     1.2.7 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
wb-mqtt-knx:
  Installed: 0.1.2
  Candidate: 0.1.2
  Version table:
 *** 0.1.2 990
        990 http://deb.wirenboard.com/wb5/stretch stable/main armel Packages
        100 /var/lib/dpkg/status
wbulgarian:
  Installed: (none)
  Candidate: 4.1-3
  Version table:
     4.1-3 500
        500 http://deb.debian.org/debian stretch/main armel Packages

Попробуйте перезагрузить контроллер. Если ничего не изменится выполните в консоли команды, чтобы проверить статус работы сервисов и версии установленных пакетов:

systemctl list-units --type=service > /root/services.txt
dpkg -l > /root/packages.txt

Файлы /root/services.txt и /root/packages.txt пришлите.

services.txt (5.4 КБ)
packages.txt (52.8 КБ)

Попробуйте перезагрузить страницу со сбросом кэша бразуера (Ctrl+F5 для Chrome) или открыть в приватном окне, чтобы заново загрузить веб-интерфейс с контроллера.

CTRL F5 помогло. Спасибо.

1 Like

Эта тема была автоматически закрыта через 7 дней после последнего ответа. В ней больше нельзя отвечать.