Второй MIO-E не работает


#1

Добрый день! Не получается настроить модули через WB MIO-E. Есть два MIO-E, через первый настроено и все ок, точно также добавляю аналогичные модули через второй. Они появляются, но не работают.

  1. Модуль входов 14 каналов
  2. Модуль 8 реле
    Если подключить модуль напрямую к WB - работает.

  1. Отображается красным
  2. Показывает, что все ок, но по факту не работает.
    В скриншоте выше вариант, когда был подключен только второй модуль.
    На MIO-E адрес задан через DHCP и на роутере фиксирован

В /var/log/messages пролетает строка: “WARNING: device ‘modbus_io:110:1’ register ‘<modbus_io:110:1:: 10000>’ setup failed: Serial protocol error: failed to write @ 10000: Serial protocol error: request timed out”

При подключении через RS-485 к первому rs порту WB выдает вот такую ошибку:
“failed to read 14 coil(s) @ 0 of device modbus_io:112:1: Serial protocol error: request timed out”


#2

Добрый день, mazaxaka!
Хотел бы попросить вас прислать скриншот с настройками устройств в случае использования первого модуля и второго.


#3

Во втором устройстве порт 20109 так как предположил, что в этом может быть проблема, но, как и следовало ожидать, это предположение не подтвердилось.


#4

А с modbus-адресом 110 у вас какое устройство:

Модуль 192.168.24.23 пингуется с контроллера ? Modbus-адрес модуля точно 112?
Можно еще попросить вас показать скриншот экрана “Serial port” веб-интерфейса модуля?


#5

У меня был еще один адаптер. Пробовал с обоими, не работает. 110 и 112 пробовал в разное время. сейчас стоит 112. Пинг есть.


#6

Ответил выше, еще какие-то данные нужны?


#7

Похоже, я смог воспроизвести вашу проблему. Разбираемся. Я попросил бы вас указать серийные номера обоих WB-MIO-E. Спасибо!


#8

Это 110 блок, 112 смогу позже сегодня прислать. Сейчас нахожусь не около него, а фото не сделал. Серийник в интерфейсе не посмотреть?


#9

Если он только по Ethernet подключен, то сложно. Проще глазами.


#10

Заехал туда сегодня, сфоткал.


#11

И 110, и 112 — не работают у вас, верно?


#12

Верно.


#13

Но один у меня работает. 48 адрес. Фотки серийника нет и его тяжело снять будет. Его мне в декабре привезли, он сразу заработал, с ним проблем не было. Сейчас в интерфейсе он добавлен. Могу попробовать его удалить, чтобы посмотеть, будет ли в качестве единственного работать 110 или 112. Но, если эта проверка не нужна, то я бы так делать не хотел.


#14

Нет, можно не трогать пока, спасибо!


#15

Скажите, вы можете прислать содержимое holding-регистров 990-997 неисправного WB-MIO-E при подключенных боковых модулях?


#16


#17

mazaxaka, это похоже на неисправность WB-MIO-E. В партии Batch N281 мы выявили неисправные устройства. Ваши модули можно заменить бесплатно. Сегодня вы должны получить письмо по электронной почте, указанной вами при заказе оборудования, с информацией о том, попало ли ваше устройство в партию, где мы обнаружили неисправность, и информацией о порядке замены.
Извините за этот неприятный инцидент.


#18

Понятно, спасибо! Буду ждать письмо.


#19

Хотел уточнить, когда будет письмо. И раз мы уже разобрались, может уже можно отправить исправные блоки? А я вам потом пришлю неисправные. Хочется уже наконец свет в хозяйственном домике включить.


#20

Добрый день, постараемся отправить вам исправные устройства сегодня.
Напишите, пожалуйста, на info@contactless.ru и прикрепите ссылку на эту страницу.
Детали замены обсудим там.