Подключение кондиционера daikin через rtd-ra

Добрый день! Пытаюсь установить связь с блоком переходником кондиционера daikin не удается это сделать. Сам блок как раз предназначен для управления кондиционером через modbus.
Вот инструкция к устройству http://www.realtime-controls.co.uk/rtd/EN%20RTD-RA%20Installation%20Instructions%2021070-1.07.pdf

Кондиционер подключен к устройству, но не подключен к внешнему блоку. Хотя ошибку по идее я должен мочь прочитать и состояние включен или нет как я думаю. Не получается связаться и что либо прочитать из rtd-ra
Устройство подключено на /dev/ttyRS485-1
Адрес как и указано в инструкции установлен в 1 (8ой переключатель на плате)
По диодам устройство вроде функционирует нормально, все зеленое

Пробовали программой modbus_client ( ответ всегда таймаут
ERROR Connection timed out: select
ERROR occured! )

Один момент когда сервис wb-mqtt-serial работает моргает диод rs485 (четвертый диод) на устройстве
Когда серис wb-mqtt-serial остановлен на устройстве четвертый диод (rs485) не моргает
То есть как-то он реагирует на это. (идет какой-то сигнал в шине? )

Команда выглядела так например modbus_client --debug -mrtu -pnone -s1 /dev/ttyRS485-1 -a1 -t0x03 -r0x05
Это попытка считать влк/выкл
Насколько я понимаю скорость и бит четности по умолчанию стандартные 9600 и 1 адрес указан тоже верно вроде.
Возможно что-то не корректно в регистрах я пока не очень разбираюсь как корректно записывать. Но в другом случае все работало (в другом устройстве ) но там ясно было дано что куда писать и как считывать а тут не очень понятно возможно напортачил…

Устройство скорее всего исправно так как пробовали два результат один таймаут, возможно где-то ошибка в команде или в понимании…
Спасибо большое за внимание к теме!

Земля соединена?

In addition the common terminal GND on
all devices must be connected together.

Так?
Screenshot from 2021-03-16 17-48-23

Если в wb-mqtt-serial что-то для порта настроено - он циклически опрашивает устойство, да.
Перед тем как проверять связь с помощью modbus_client обязательно остановить wb-mqtt-serial.

Команда - верна. А что-то еще подключено на ту же шину?

спасибо за ответ. Земля соединена с wb напрямую. Ну то есть земля-земля.
wb-mqtt-serial был остановлен. Потом был включен для просто теста но ничего не поменялось.
Потом был сервис остановлен опять.
Пока тестировали просто на шине больше ничего нет кроме rtd-ra. До этого разные устройства так же тестировались и стандартные WB наверное что-то настроено, но сейчас на шине одно устройство.
Адрес как на картинке выставлен в единицу.
Я думал может адресация неверная или регистры, может как-то по другому надо записать. В их инструкции все написано с нулями впереди, но ведь нули добиваются насколько я понимаю в шестнадцатеричный формат. И не понятно должно что-то отвечать устройство или нет. Но два устройства оба глухо как будто не ничего на шине нет, при этом горит все зеленым. получается на опрос он тоже реагирует.
Вроде устройство довольно распространенное я поэтому думал делаю что-то не так…

То есть опросы он получается как-то чувствует? Но на отправленные модбас клиентом команды не реагирует так как не моргает лампочка rs485 да и таймаут сразу происходит

Нашел в статьях производителя такую заметку
If Modbus is used LED 4 should be flashing indicating that data is being exchanged over the RS485 line.
Получается на опрос контроллера он действительно реагирует… В чем же может быть ошибка при использовании modbus_client или отличие от опроса?
При широковещательных запросах на адрес 0 так же нет реакции (моргания диода)

А в настройках wb-mqtt-serial для порта какие параметры? 9600 N s2?

Добрый день, да все так.

Попробуйте тоже использовать -s2 и широковещательный адрес?

Здравствуйте, похоже что-то с контроллером чтоли. Не уверен но пытались отправить команду диммеру, и результат оказался тем же. Может что-то не то делаем… Но раньше связаться удавалось и получить ответ, отдавать команды и получать ответ с помощью modbus_client. По стандартному адресу 114 связаться не удалось (адрес писали как 0х72 в 16ричном формате, верно?) Хотя адрес не меняли, но вдруг, решено было поменять как в документации на второй сначала (на шине один диммер) потом обратиться по второму адресу, но ответ таймаут (см приложенный скрин). Притом набор байт отправляемый на смену адреса широковещательным вариантом и последующее обращения для тестового считывания совпадают с тем что приводится в документации, контрольная сумма тоже, не уверен что понимаю что происходит может что-то с контроллером… В данном варианте использовалась вторая линия, на первой был тот же результат, поэтому перегрузили все поменяли линию но ничего не изменилось. Если можно подскажите, что можно посмотреть или как еще потестировать, есть другие устройства если диммер не подходит… Подскажите, куда можно копнуть ? Спасибо большое!

В обоих случаях ответа от устройства нет, давайте удаленный доступ - посмотрю.

Можете дать ссылку на материалы как сделать удаленный доступ к устройству? Есть ли какая инструкция или статья? В данный момент устройство к интернету не подключено. Локально просто соединено, для тестов.
ps Нашел материалы, будем пробовать делать. Нужен статический айпи, нужно проводить подключение к объекту. Думал может есть у вас сервер куда можно инициировать подключение с нашей стороны.
Пока пробуем не подскажете, что можно посмотреть, потыкать самостоятельно?
Благодарю

pps Так же устройства перестали в веб интерфейсе определяться. Ранее несколько устройств были добавлены для тестирования, все определялось по стандартным адресам, работало. Теперь нет, возможно из-за отключения устройств от шины? Видимо в процессе проб что-то поломали на контроллере…

Достаточно доступа к порту 22 TCP из интернета.
Можете просто поставить на компьютер, подключенный к контроллеру anydesk. И номер - мне в ЛС. Или в телеграм, ник тот же.

Для истории: при подключении портов /dev/ttyRS485-1 к 2 - связи между ними нет. Пробуем
https://wirenboard.com/wiki/Обновление_прошивки#.D0.A1.D0.B1.D1.80.D0.BE.D1.81_Wiren_Board_6_.D0.BA_.D0.B7.D0.B0.D0.B2.D0.BE.D0.B4.D1.81.D0.BA.D0.B8.D0.BC_.D0.BD.D0.B0.D1.81.D1.82.D1.80.D0.BE.D0.B9.D0.BA.D0.B0.D0.BC

Большое спасибо, что посмотрели!! Будем пробовать!

Сделали по инструкции, но дело было не в контроллере, ошибочно было подключено питание. Стандартные устройства теперь видимы. Блок кондиционера еще не пробовали, по результатам отпишусь (сейчас нет возможности попробовать)
Спасибо большое Андрей!

Всегда пожалуйста. А насчет кондиционера - сам блок упроавления был подключен к внктреннему блоку? Внешний блок у этой модели подключается по 5 проводам или тоже с цифровой шиной?
И да, пожет быть неверная маркировка все же A и B:

Доброго дня! Когда тестировали адаптер (плата которая конвертирует из/в модбас) был подключен к блоку кондиционера внутреннему, к внешнему все это не было подключено. Пока сказать как внешний блок подключается не могу, так как не знаю. Но судя по инструкции плата должна отвечать ошибкой об отсутствии видимости внешнего блока, то есть в общем той ошибкой которая появляется на внутреннем блоке, если нет связи с внешним.
Заказали шнурок USB, а у производителя платы есть программа, они рекомендовали потестить с ней. Пока просто там уже убрали все, нет возможности потестить. О результатах напишу как только будет понятно работает оно или нет. Спасибо за советы Андрей!!

1 симпатия

Это не кондиционер, а вентмашина СистемАир, контроллер тоже этого производителя. Собиралось в европе. Как то странно сто перепутали полюса. Производитель не новый, с большим опитом.

Полагаю в данном случае имелся ввиду сам факт того, что не стоит доверять маркировке, иногда “и на старуху бывает проруха”, какой-бы производитель не был. Будем пробовать, просто сейчас уже отделка пошла, и все электронное пока убрано/упаковано. Вам спасибо за Ваш опыт, очень полезно!

1 симпатия