Проблема с подключением к Wi-Fi

Пробовал настраивать по инструкции с сайта, перепробовал и автоматический режим и ручной. Переводил точку доступа на роутере с WPA2-Personal на WPA и обратно.
Не удается подключиться к Wi-Fi никак.

HW 7.3.2A/3
SN AB5NGGDH




interfaces (745 Bytes)
diag_output_AB5NGGDH_2022-09-05-14.zip (193.0 KB)

Здравствуйте!
Попробуйте без кавычек название сети вводить:

auto wlan0
iface wlan0 inet dhcp
  wpa-ssid G-Spot_2
  wpa-psk 1231231231234

Здравствуйте, я с этого и начинал. С ковычками или без кавычек итог один.

Добрый день. Проблема на канальном уровне, это очевидно из вывода:


Я вижу точно и недвусмысленно указывающую на причину строку, в которй важным является auth_failures/

Добрый день. Мне немного не очевидно. Приведенная вами часть скриншота результат действий:

  • WPA2-PSK:
  1. Сгенерируйте файл с учётной записью для подключения к точке доступа:

wpa_passphrase ИмяТочкиДоступа ПарольОтТочкиДоступа > /root/wpa.conf

  1. Установите подключение с использованием сгенерированного файла:

wpa_supplicant -Dwext -iwlan0 -c/root/wpa.conf &

Специально повторил шаги, сгенерировав файл заново, видно что он ничем не отличается от того что был на первом моем скриншоте и с которым я пытался подключиться:

Попытка подключения выдает тот же лог:

К данной точке подключается ноутбук без проблем c этим же паролем. Метод проверки подлинности вроде бы правильный:

Опять же, это я уже начал пробовать все способы которые были в инструкции от безысходности. Ожидания были что достаточно будет прописать имя точки и пароль в /etc/network/interfaces

Теряюсь в догадках куда еще копать.

Воспроизвожу.
Точка доступа настроена так:

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=\
    WPA supplicant-identity="" wpa2-pre-shared-key=********

iwlist wlan0 scanning |grep SSID
                    ESSID:"WirenBoard-ANHVBI4B"
                    ESSID:"TerHorse_Global"
                    ESSID:"WirenBoard-ACAX3M6K"
                    ESSID:"TerHorse_Global"

Иду по инструкции.

wpa_passphrase TerHorse_Global ******** > /root/wpa.conf

wpa_supplicant -Dwext -iwlan0 -c/root/wpa.conf &
[1] 16941
root@wirenboard-AQASN7R6:~# Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
wlan0: Trying to associate with 64:d1:54:f4:83:34 (SSID='TerHorse_Global' freq=2452 MHz)
wlan0: Associated with 64:d1:54:f4:83:34
wlan0: WPA: Key negotiation completed with 64:d1:54:f4:83:34 [PTK=CCMP GTK=CCMP]
wlan0: CTRL-EVENT-CONNECTED - Connection to 64:d1:54:f4:83:34 completed [id=0 id_str=]

Ну и адрес получается вполне нормально.

При этом на точке в логах стандартное:
F0:C8:14:49:F3:DA@wlan1: connected, signal strength -51

Не знаю с чем это связано. Поменял название на более простое gspot. Заменил название в /etc/network/interfaces попробовал подключиться ifdown wlan0 && ifup wlan0
Все заработало без каких-то проблем. Считаю что проблема решена.

1 Like

У меня название тоже с большими-маленькими и знаком подчеркивания. Точно не в имени. Вот если ошибка в нем была - да.

Возможно роутер при смене имени переконфигурил точку и какая-то внутренняя проблема роутера решилась сама собой. Имя точно правильное было, я не один раз это проверял и чаще всего копировал его из вывода консоли или из настроек роутера.

Эта тема была автоматически закрыта через 7 дней после последнего ответа. В ней больше нельзя отвечать.