Проблема с WBE2R-R-ZIGBEE v.2

Добрый день! Столкнулся с аналогичной проблемой. Переустанавливал модуль в другой порт - тоже не помогло, переустанавливал zigbee2mqtt.

Добрый день.
Перенес ваш вопрос в новую тему, т.к. возможны разные причины проблемы.
Пришлите диагностический архив, укажите ревизию контроллера и версию ПО. Пришлите лог zigbee2mqtt.
Опишите подробнее, что делаете, что ожидаете получить, что получаете.

HW Revision 7.3.4
Release name wb-2310
Версия модуля ZigBee: v2.2

Файл диагностики: diag_output_AKYA7CAQ_2024-01-13-10.46.20.zip (205,9 КБ)
Скрин лога работы службы zigbee2mqtt:

Журнал работы службы:

Устанавливал модуль ZigBee по инструкции:
https://wirenboard.com/wiki/Zigbee

Конечно же хотел получить работающий модуль ZigBee. Сканирование устройств не даёт результата в поиске новых устройств ZigBee. Модуль установлен в MOD4 (переустанавливал в другие порты) - безрезультатно. В конфигурации /etc/wb-hardware.conf указан верно порт подключения. Также не работает web-интерфейс zigbee2mqtt с настройкой:
frontend:
port: 8081
host: 0.0.0.0

Спасибо.

Но в журнеле ведь предельно подробно описано - что pan id и ключ адаптера не совпадают с тем что указано в конфиге. Либо приведите значения в соответствии настройкам адаптера либо удалите бэкап координатора - это дословно.

В конфиге в соответствие с руководством установлено:

pan_id: GENERATE
network_key: GENERATE

image

При запуске эти значения видимо генерируются.
Далее служба падает в ошибку, после при открытии конфига установлены случайные числа в данных полях.

Где в инструкции черным по белому “подробно описано” об этом?

Поменял вручную, вместо GENERATE указал тот ID, который указан в логе

Уточните в какой слот установлен модуль. Судя по файлу настройки конфигурации wb-hardware.conf модуль установлен в первый слот, в настройках configuration.yaml указан четвертый. Исправьте и сообщите о результате.

Точно установлен в MOD4. Менял на другие порты, проблема аналогичная

Сложно диагностировать, когда в архиве вижу одно, а на скринах другое.
Оставьте модуль в одном из портов. Выполните все настройки, как указано в документации. Проверьте работоспособность.
Пришлите диагностический архив. Пришлите лог zigbee2mqtt.
Просьба логи присылать или как указано в Правила - Wiren Board Support (скрины сложно читать).

Порт, к которому подключено устройство:

cat /etc/wb-hardware.conf
{
“mod4”: {
“module”: “wbe2r-r-zigbee”,
“options”: {}
},
“wbmz”: {
“module”: “wbmz4-battery”,
“options”: {}
}
}

root@wirenboard-****:~/zigbee2mqtt/data# cat /etc/wb-mqtt-serial.conf
{
“debug” : false,
“ports” :
[
{
“baud_rate” : 9600,
“data_bits” : 8,
“devices” : [],
“enabled” : true,
“parity” : “N”,
“path” : “/dev/ttyRS485-1”,
“port_type” : “serial”,
“stop_bits” : 2
},
{
“baud_rate” : 9600,
“data_bits” : 8,
“devices” : [],
“enabled” : true,
“parity” : “N”,
“path” : “/dev/ttyRS485-2”,
“stop_bits” : 2
},
{
“baud_rate” : 115200,
“data_bits” : 8,
“devices” : [],
“enabled” : false,
“parity” : “N”,
“path” : “/dev/ttyMOD1”,
“stop_bits” : 2
},
{
“baud_rate” : 9600,
“data_bits” : 8,
“devices” : [],
“enabled” : false,
“parity” : “N”,
“path” : “/dev/ttyMOD2”,
“stop_bits” : 2
},
{
“baud_rate” : 9600,
“data_bits” : 8,
“devices” : [],
“enabled” : false,
“parity” : “N”,
“path” : “/dev/ttyMOD3”,
“stop_bits” : 2
},
{
“baud_rate” : 115200, (Пробовал и на 9600)
“data_bits” : 8,
“devices” : [],
“enabled” : true,
“parity” : “N”,
“path” : “/dev/ttyMOD4”,
“stop_bits” : 2
},
{
“address” : “***.***.***.***”,
“devices” :
[
{
“channels” :
[
{
“address” : “83”,
“format” : “s16”,
“name” : “RS485”,
“offset” : 0,
“reg_type” : “position”,
“scale” : 1,
“type” : “value”
}
],
“protocol” : “modbus_io”,
“slave_id” : “43:2”
},
{
“device_type” : “WBIO-DI-WD-14”,
“slave_id” : “43:1”
}
],
“enabled” : true,
“port” : 23,
“port_type” : “tcp”
},
{
“address” : “***.***.***.***”,
“devices” :
[
{
“channels” :
[
{
“address” : “83”,
“format” : “s16”,
“name” : “RS485”,
“offset” : 0,
“reg_type” : “position”,
“scale” : 1,
“type” : “value”
}
],
“protocol” : “modbus_io”,
“slave_id” : “83”
}
],
“enabled” : true,
“port” : 23,
“port_type” : “tcp”
}
]

Файл configuration.yaml

homeassistant: false
permit_join: false
mqtt:
base_topic: zigbee2mqtt
server: ‘mqtt://localhost’
serial:
port: /dev/ttyMOD4
advanced:
rtscts: false
last_seen: epoch
pan_id: GENERATE
network_key: GENERATE

Далее запускаю сервис, конфигурация становится такой:

homeassistant: false
permit_join: false
mqtt:
base_topic: zigbee2mqtt
server: mqtt://localhost
serial:
port: /dev/ttyMOD4
advanced:
rtscts: false
last_seen: epoch
pan_id: 39370
network_key:
- 56
- 12
- 247
- 80
- 158
- 140
- 157
- 78
- 223
- 187
- 111
- 245
- 146
- 21
- 127
- 169

Лог запуска zigbee2mqtt:

log.txt (2,0 КБ)

Меняю PAN ID:

homeassistant: false
permit_join: false
mqtt:
base_topic: zigbee2mqtt
server: mqtt://localhost
serial:
port: /dev/ttyMOD4
advanced:
rtscts: false
last_seen: epoch
pan_id: 11629
network_key:
- 56
- 12
- 247
- 80
- 158
- 140
- 157
- 78
- 223
- 187
- 111
- 245
- 146
- 21
- 127
- 169

log.txt (2,0 КБ)

приложен диагностический архив, доступен только сотрудникам поддержки
(174,1 КБ)

Не в инструкции, прямо в логах на скриншоте, что вы опубликовали:


Очевидно что проблем со связью с самим адаптером нет, так как его параметры читаются.
Различается network key, про это и написано.

Можете закрывать тему. Я самостоятельно решил проблему. Об этом ни слова в вашей инструкции по установке zigbee2mqtt

Поделитесь опытом. Добавим в документацию.

Аналогичная проблема. Что было то?

В итоге решил: в логах написано, что необхоимо удалить бекапный coordinator_backup.json
После удаления все поднялось, Так же в логе просят поднять версию node
Zigbee2MQTT requires node version ^18 || ^20 || ^21, you are running v16.18.1!

1 Like