Проблемы с установкой ПО Z way

Итак контроллер WB 6 c установлена прошивка 202002171718 в режиме factory reset.
Далее следую вашей инструкции на wiki “Установка ПО на Wiren Board 6 (новый способ)”
1и2 пункт из инструкции проходят успешно

А на 3м пункте контроллер вываливает ошибку:
root@wirenboard-AAWNMFLN:~# dpkg -i z-way-2.3.8_armhf.deb
dpkg-deb: error: ‘z-way-2.3.8_armhf.deb’ is not a debian format archive
dpkg: error processing archive z-way-2.3.8_armhf.deb (–install):
subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
z-way-2.3.8_armhf.deb

Подскажите в чем проблема?

Судя по всему, проблема с файлом. Удалите и попробуйте скачать заново.

пробовал скачивал несколько раз на 2 контроллерах и с разными источниками интернета
Возможно есть альтернативная ссылка на файл (не из вашего wiki)?

Проверил, господа из z-wave.me зачем-то изменили адрес и название файла.
В вики поменял, теперь должно работать. Следите за размером файла - должен быть около 20 Мбайт.

1 Симпатия

Спасибо, помогло

Снова пытаюсь установить на очередной контроллер WB6 ПО Z way по инструкции
и запинаюсь на теперь на пункте 2:
root@wirenboard-AMPFYTR5:~# apt install libarchive13 sharutils gawk libavahi-compat-libdnssd-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package gawk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘gawk’ has no installation candidate
E: Unable to locate package libavahi-compat-libdnssd-dev

Что делать?

Добрый день!
Извиняюсь за задержку с ответом.
Попробуйте, пожалуйста, пропустить этот пункт, то есть:

  1. Выполнить
apt update; apt upgrade
wget https://storage.z-wave.me/z-way-server/z-way-2.3.8__armhf.deb
dpkg -i z-way-2.3.8__armhf.deb
  1. Затем выполнить
apt --fix-broken install

и пришлите, пожалуйста, вывод всех этих команд.

Итак
команды
apt update; apt upgrade
wget https://storage.z-wave.me/z-way-server/z-way-2.3.8__armhf.deb
отработали - все ок

Следующая команда отработала с ошибкой

root@wirenboard-AMPFYTR5:~# dpkg -i z-way-2.3.8__armhf.deb
Selecting previously unselected package z-way-server.
(Reading database … 27771 files and directories currently installed.)
Preparing to unpack z-way-2.3.8__armhf.deb …
Unpacking z-way-server (2.3.8) …
dpkg: dependency problems prevent configuration of z-way-server:
z-way-server depends on libarchive13 (>= 3.0); however:
Package libarchive13 is not installed.
z-way-server depends on sharutils; however:
Package sharutils is not installed.
z-way-server depends on gawk; however:
Package gawk is not installed.
z-way-server depends on libavahi-compat-libdnssd-dev; however:
Package libavahi-compat-libdnssd-dev is not installed.

dpkg: error processing package z-way-server (–install):
dependency problems - leaving unconfigured
Processing triggers for systemd (232-25+deb9u12) …
Errors were encountered while processing:
z-way-server
root@wirenboard-AMPFYTR5:~#

Попробуйте устанавливать с помощью apt. Команда

apt install z-way-2.3.8__armhf.deb

самостоятельно установит зависимости.

root@wirenboard-AMPFYTR5:~# apt install z-way-2.3.8__armhf.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package z-way-2.3.8__armhf.deb
E: Couldn’t find any package by glob ‘z-way-2.3.8__armhf.deb’
E: Couldn’t find any package by regex ‘z-way-2.3.8__armhf.deb’
root@wirenboard-AMPFYTR5:~#

Ошибся я.

apt install ./z-way-2.3.8__armhf.deb

выполнил…
затем
apt --fix-broken install


Setting up libavahi-compat-libdnssd-dev:armhf (0.6.32-2) …
Setting up z-way-server (2.3.8) …
Setting default automation config
sed: can’t read /boot/cmdline.txt: No such file or directory
Usage: ./z-cfg-update
Starting z-way-server: done.

далее какие пункты по мануалу выполнять?

Так, мы же по https://wirenboard.com/wiki/Z-Wave этой инструкции?
Значит с 4 пункта.

все получилось
вижу сервер по адресу адрес:8083
z-wave устройство датчик протечки philio pat02-5c подключился
Но я его не вижу в интерфейсе WB во вкладке device
и нет пункта настроек z-way во вкладке config

А 5 пункт выполнен?

Заработало после повторного выполнения пункта 5

1 Симпатия