Контроллер не загружается с первого раза

Добрый день!
Недавно приобрел контроллер и сразу же с ним начались какие-то проблемы: он далеко не всегда грузится с первого раза корректно. Пробовал делать factory reset, но не похоже, что это решает проблему. Во вложении лог с дебаг консоли, там я попробовал дважды сделать ресет. По логу видно, что контроллер зависает на разных стадиях загрузки:

  • может на этапе “Press FW button to enter firmware update mode”
  • может на этапе “Hit key to stop autoboot in 1s”
  • может на этапе запуска ядра

Помогите пожалуйста разобраться с проблемой. У меня подозрение, что это что-то аппаратное…
Заранее спасибо!
MobaXterm_COM5USBCOM5_20240315_214546.rtf (248,3 КБ)

Добрый день.
Серийный номер как понимаю A7GET2OH
Несколько вопросов:

От чего (какой блок питания) работает контроллер?
Зачем к нему подключен Network Debug интерфейс?
Ну и - при штатном подключении попробуйте несколько раз программно перезапустить контроллер, без подключенного Network Debug и пришлите лог пожалуйста.

штатное подключение - через LI60-20B24PR2 и WB-UPS v.2, на ИБП включено 24В.
Дебаг консолью подключался, чтобы посмотреть, что там вообще происходит с ним при загрузке, так как МК после ребута недоступен по wi-fi. Когда подключался дебаг консолью, от МК была отключена вся периферия и сам он подключен только к ПК по USB к дебаг консоли.

Сейчас попробовал включить МК штатно и без подключения к дебаг консоли (он был выключен долгое время, несколько дней). Он включился штатно и быстро. Как только он загрузился, я зашел на него по ssh и выполнил reboot. Он ушел в ребут и оттуда пока что не вернулся: на самом МК постоянно горит желтый светодиод, иногда сменяясь на постоянный зеленый. Ну то есть видно, что он даже не пытается запустить ОС (нет красного мигающего светодиода).
Как загрузится, попробую снять логи. Подскажите, как лучше это сделать?

Подключитесь в Debug порт, не отключайте блок питания - ну и выложите вывод оттуда.

Пока отходил, МК загрузился, не ранее, чем через полчаса после того, как я его в ребут послал.
Подключился к Debug Console без отключения основного питания, зашел и ребутнул. Ребут опять длился очень долго. Лог во вложении с момента подключения консолью до момента полного старта.

18.03.2024, 19:04, “Андрей Радионов через Wiren Board Support” <info@wirenboard.com>:

MobaXterm_COM5USBCOM5_20240318_200207.rtf (139 KB)

Явно аппаратное, высоковероятно неполадки с RAM.
Давайте мы бесплатно поменяем вам оборудование. Курьер привезёт новое оборудование и заберёт старое:

  • WB7.4 - 1 шт

Для возврата напишите, пожалуйста, письмо на info@wirenboard.com.

В письме укажите:

  1. ссылку на эту тему,
  2. серийный номер устройства, A7GET2OH,
  3. ваш действующий телефон, адрес доставки, ФИО получателя.

Да, давайте. Только вопрос: у меня там модуль спрута стоит, мне его вытащить и оставить у себя, или вы привезете с новым модулем?

Получил ответ от менеджера, пришлют вместе с новым модулем.
Андрей, спасибо Вам большое за помощь!

1 Like