Настройка модуля KNX на WB6.5


#1

Добрый день!
Установил в контроллер WB6.5 модуль KNX. При настройке возникли трудности.
Выполнял все согласно инструкции на вики: Вики по KNX

  1. В вебе контроллера указал KNX модуль
  2. В консоли начались траблы:
    apt-get update - отработал и, вроде, все ок
    на запрос apt-get install knxd knxd-tools wb-mqtt-knx консоль выдала ряд сообщений о невозможности установки:
    root@wirenboard-ALXMEYEN:~# apt-get install knxd knxd-tools wb-mqtt-knx
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    You might want to run ‘apt --fix-broken install’ to correct these.
    The following packages have unmet dependencies:
    knxd : Depends: libpthsem20 but it is not going to be installed
    knxd-tools : Depends: libpthsem20 but it is not going to be installed
    wb-mqtt-zway : Depends: z-way-server (>= 2.2.0) but it is not installable
    E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution)

    “fix broken install” не выполнял, т.к. он мне один раз уже все сломал.
    К шагу №3 не приступил, т.к. файла knxd в дереве не появилось.
    Подскажите, пжст, как быть.
    Спасибо!

#2

Евгений, добрый день!
Да, по-прежнему, компоненты z-way ломают зависимости.
Попробуйте выполнить следующие действия:
Создайте резервную копию /etc/wb-mqtt-zway.conf

    apt-get update

    apt --fix-broken install

    apt-get download wb-mqtt-zway wb-homa-zway knxd knxd-tools wb-mqtt-knx

    dpkg -i --force-all wb-mqtt-zway_1.0.3+wb2_armhf.deb wb-homa-zway_1.0.3+wb2_all.deb knxd_0.11.15-1-wb1_armhf.deb knxd-tools_0.11.15-1-wb1_armhf.deb wb-mqtt-knx_0.1.2_armhf.deb