Проблема со стартом KNXD

Здравствуйте!
Имеем контроллер WB6.5, модуль WBE2-I-KNX стоит в Slot1.
В журнале наблюдая следующее:

31-08-2022 12:48:33.094 [init.scope] knxd.service: Failed with result ‘exit-code’.
31-08-2022 12:48:33.088 [init.scope] knxd.service: Unit entered failed state.
31-08-2022 12:48:33.081 [init.scope] Failed to start KNX Daemon.
31-08-2022 12:48:33.074 [init.scope] knxd.service: Main process exited, code=exited, status=217/USER
31-08-2022 12:48:33.055 [knxd] knxd.service: Failed at step USER spawning /usr/bin/knxd: No such process
31-08-2022 12:48:33.044 [init.scope] Starting KNX Daemon…
31-08-2022 12:48:33.021 [init.scope] Stopped KNX Daemon.
31-08-2022 12:48:33.010 [init.scope] knxd.service: Service hold-off time over, scheduling restart.

Здравствуйте!
Обновлено ли ПО контроллера? Какой релиз ПО на контроллере установлен?
Сконфигурирован ли модуль в настройках контроллера:

Перезагрузите контроллер. Если перезагрузка не поможет, то попробуйте перезапустить сервис вручную:

systemctl restart knxd

а затем проверьте его статус:

systemctl status knxd

Проверьте файл настроек сервиса knxd (/etc/systemd/system/multi-user.target.wants/knxd.service). Вот тут описана подобная проблема:
https://super-unix.com/superuser/what-causes-systemd-failed-at-step-user-spawning-usr-sbin-opendkim-no-such-process/

Пришлите, пожалуйста, файлы

/etc/systemd/system/multi-user.target.wants/knxd.service
/etc/knxd.conf

Также для диагностики проблемы пришлите, пожалуйста, архив с диагностической информацией контроллера. Создание архива описано в инструкции.

Если не подключена линия knx (нет питания 30v на клеммах knx), то сервис knxd все время перезагружается. Это нормально.

Если knx подключена, то копайте настройки knxd.conf

1 Like

30 вольт на клемы WB приходят

По обновлено, релиз стоит wb-2204

вот ответы на попытку перезапустить и просмотр статуса
root@wirenboard-AIXLIGY:~# systemctl restart knxd
Job for knxd.service failed because the control process exited with error code.
See “systemctl status knxd.service” and “journalctl -xe” for details.
root@wirenboard-AIXLIGY:~# systemctl status knxd
● knxd.service - KNX Daemon
Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: ena
Active: activating (auto-restart) (Result: exit-code) since Wed 2022-08-31 10
Process: 20851 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=217/USE
Main PID: 20851 (code=exited, status=217/USER)

Aug 31 10:01:19 wirenboard-AIXLIGY systemd[1]: knxd.service: Failed with result
lines 1-7/7 (END)
● knxd.service - KNX Daemon
Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2022-08-31 10:01:19 UTC; 869ms
Process: 20851 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=217/USER)
Main PID: 20851 (code=exited, status=217/USER)

Aug 31 10:01:19 wirenboard-AIXLIGY systemd[1]: knxd.service: Failed with result ‘exit-code’.

diag_output_AIXLIGY_2022-08-31-10.04.45.zip (75.6 КБ)

Вот эти файлы пришлите, пожалуйста.
Посмотрите лог службы knxd:

journalctl -u knxd

knxd.service (305 Байт)
knxd.conf (215 Байт)

журнал knx.txt (5.6 КБ)

Как я понимаю, проблема с запуском сервиса knxd службой systemd.
Попробуйте остановить сервис и запустить его вручную так:

systemctl stop knxd
/usr/bin/knxd -e 1.1.2 -E 1.1.3:50 -D -T -R -n WirenboardKNX -S 224.0.23.12:3671 -b ncn5120:/dev/ttyKNX

Покажите вывод команды.

root@wirenboard-AIXLIGY:~# systemctl stop knxd
Warning: Stopping knxd.service, but it can still be activated by:
knxd.socket

Теперь это

на это просто тишина

Ошибок при запуске не вижу.
Остановите еще, пожалуйста, и сервис knxd.socket, а затем снова запуск вручную и проверьте, работает ли knxd:

systemctl stop knxd.socket
systemctl stop knxd.service
/usr/bin/knxd -e 1.1.2 -E 1.1.3:50 -D -T -R -n WirenboardKNX -S 224.0.23.12:3671 -b ncn5120:/dev/ttyKNX

Проверьте, запущен ли knxd:

ps -ax | grep knx

на запуск снова тишина
root@wirenboard-AIXLIGY:~# ps -ax | grep knx 1641 ? Ssl 0:34 /usr/bin/wb-mqtt-knx
28664 pts/0 S+ 0:00 grep knx

Попробуйте еще изменить в файле конфигурации /etc/systemd/system/multi-user.target.wants/knxd.service пользователя на root, а группу совсем убрать:

[Unit]
Description=KNX Daemon
After=network.target knxd.socket
Requires=knxd.socket

[Service]
EnvironmentFile=/etc/knxd.conf
ExecStart=/usr/bin/knxd $KNXD_OPTS
User=root
Type=notify

Restart=on-failure
RestartSec=10

[Install]
WantedBy=multi-user.target network-online.target
Also=knxd.socket

Затем запустите сервисы:

systemctl start knxd.socket
systemctl start knxd.service

завелось, пошло управление по групповым адресам, по крайней мере команда вкл/выкл прошла

Завтра проверю все еще раз и отпишусь