Не запускается KNXD

Добрый день, никак не получается запустить knxd.
Сам модуль установлен в MOD3.
Версия прошивки wb-2404.
При попытке получить статус выдает вот это:

Выполнил все необходимые настройки как в инструкции:

  1. Указал в настройках внутреннего слота модуль расширения

  1. В wb-knxd-config.conf ничего не трогал


нашел на форуме похожую тему (Проблема со стартом KNXD) - попробовал рекомендации из нее - безрезультатно.

содержимое файла knxd.service

[Unit]
Description=KNX Daemon
After=network.target knxd.socket
Requires=knxd.socket

[Service]
EnvironmentFile=/etc/knxd.conf
ExecStart=/usr/bin/knxd $KNXD_OPTS
User=knxd
Group=knxd
Type=notify
Restart=on-failure
RestartSec=10

[Install]
WantedBy=multi-user.target network-online.target
Also=knxd.socket

содержимое файла knxd.conf

# This file is automatically generated by /etc/wb-knxd-config.conf from wb-knxd-config. Do not edit manually.
KNXD_OPTS=" -e 0.0.1 -E 0.0.2:50 -D -T -R -n WirenboardKNX -S 224.0.23.12:3671  -b ncn5120:/dev/ttyKNX "

вот такие команды тоже пробовал

root@wirenboard-AZCAVAQE:~# systemctl stop knxd.socket
root@wirenboard-AZCAVAQE:~# systemctl stop knxd.service
root@wirenboard-AZCAVAQE:~# /usr/bin/knxd -e 1.1.2 -E 1.1.3:50 -D -T -R -n WirenboardKNX -S 224.0.23.12:3671 -b ncn5120:/dev/ttyKNX
WirenboardKNX: E00000064: [16:router] router: setup router: failed
WirenboardKNX: F00000105: [ 4:server] Link down, terminating

Не помогает (((

Добрый день.
А что в логах knxd?
Какое напряжение на шине knx?

Для диагностики проблемы пришлите, пожалуйста, архив с диагностической информацией контроллера. Создание архива описано в документации.

Вот эта команда journalctl -u knxd выдает следующее:

Напряжение измерю сегодня позже - отпишусь, но, на глаз, кажется, что все ок, так как панелька, подключенная к этой же линии - горит и работает. Архив также позже вышлю. Спасибо.

Напряжение - 30V - проверил везде
Диагностический архив

приложен диагностический архив, доступен только сотрудникам поддержки
(249,4 КБ)

Так, сконфигурирован локальный адаптер верно:

    "Interface": {
        "Layer2": "ncn5120:/dev/ttyKNX",

В hardware тоже:

    {
      "id": "wb72-mod3",
      "name": "Internal slot 3",
      "compatible": [
        "wbe2",
        "wbe3-reduced"
      ],
      "module": "wbe2-i-knx",
      "options": {}
    },

Клеммы точно используете MOD3?

А причина понятна:

3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:85:01:01:08:8a brd ff:ff:ff:ff:ff:ff
4: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:85:01:01:88:c9 brd ff:ff:ff:ff:ff:ff

К ethernet ничего не подключено, а knxd сконфигурирован быть роутером.
То есть - надо или переконфигурировать его, убрав эту настройку или подключить какой-то из ethernet портов.

Спасибо за проведенный анализ, но вопросов только больше стало (прошу прощения за мое дилетантство :slight_smile:

Настраиваю по статье Быстрый старт работы с KNX на контроллере Wiren Board — Wiren Board там, конечно, нет таких подробностей.

Вопросы

  1. Где можно посмотреть логи, которые указывают на проблемы с ethernet?

  2. Мои первичные цели сейчас если коротко

  • подключиться к wb из ETS5 (компьютер к wb подключается через wifi, раздаваемый wb)
  • попробовать толкнуть настройки на один из модулей KNX, подключенных к wb
  • подключиться к топику телеграм - попробовать почитать сообщения из шины

не понимаю где и что мне надо настроить ((

вот здесь (Knxd — Wiren Board) указано, что надо наоборот все “галки” включить для работы с ETS

в журнале knxd. Ну и неплохо сразу прочитать документацию по нему: knxd/README.md at main · knxd/knxd · GitHub

Да. Но только при работе через ethernet.
Мультикаст не будет работать через wi-fi, по крайней мере с настройками и по умолчани.

правильно я понимаю, что для того, чтобы подключиться к wb из ETS мне необходимо проводное соединение компьютера с wb? При этом не очень понятно - я могу подключиться напрямую или использовать роутер (как описано в Как узнать IP-адрес контроллера Wiren Board — Wiren Board).

В одном сегменте - практически неважно. Свитч/роутер удобнее, да.

Все получилось. Спасибо!

Оставлю здесь мой опыт, возможно кому-то пригодится.

Основная моя ошибка была в том, что я подключался к wb исключительно через его wi-fi точку доступа. После добавления в “систему” роутера и подключения к нему wb и компьютера - knxd запустился!

В принципе, если бы у меня не было под рукой роутера, то можно было бы проверить работоспособность выключением галки “Сервер (-S, --Server) Включить сервер групповых сообщений EIBnet/IP”.

Итак, я подключился через роутер, после этого с ETS проблем не возникло. Запрограммировал клавиши. Отключил роутер от wb. И важно (!) не забыть обратно снять галку “Сервер (-S, --Server) Включить сервер групповых сообщений EIBnet/IP” - иначе опять получите ошибку knxd и ничего работать не будет. И, как я понял, для ежедневной работы сервер не нужен - только для программирования или диагностики.

Предполагаю, что если бы подключался с ноутбука к роутеру через wi-fi - пробоем бы не возникло.

Авторам просьба в wiji про быстрый старт KNX явно указать, что подключение к wb должно быть через роутер по шнуру.

Еще раз благодарю авторов за поддержку…))

Да, совершенно верно. Еще нужен если есть несколько сегментов KNX, соедеиненных через Ethernet сеть и IP/KNX шлюзы.

Да, я просмотрел статью и не увидел там указания. Вот в этом и есть ценность свежего взгляда. Когда ее писал - мне казалось очевидным что подключение по Ethernet. Так что - помогаете стать лучше.

1 Like