Не запускается сервис Zigbee2mqtt после установки

Приветствую, проблема такая:

  • Контроллер WB7 был сброшен до заводских настроек, затем apt-get update и после apt-get install zigbee2mqtt.
    *Сервис запускаться отказался.

Судя по описанию, вы не настроили установленное ПО. Проверьте, что всё делаете по инструкции и, если ничего не получится, то соберите логи и пришлите их сюда текстовым файлом. Как собрать правильные логи есть в разделе Диагностика неисправностей.

Точно, в configuration.yml поставили соответствующий порт.
Модуль zigbee установлен в MOD4.
Рестарт сервиса тоже выполнял, но результата это не дало.

А логи пришлёте, которые я просил в предыдущем сообщении? Без них помочь ничем не смогу.

npm start.txt (1.5 КБ)
Это то что нужно ?

То, что нужно. Какая у вас версия модуля расширения WBE2R-R-ZIGBEE v.1 или v.2?

Если затрудняетесь, ответить, тогда хотя бы когда покупали?

1.2v

1 Like

Отлично, должно работать, попробуйте перезагрузить контроллер кнопкой: выключить и включить. Это сбросит ресет с модуля и, возможно, решит проблему.

Если проблема не решится, то пришлите ваш файл configuration.yaml.

Я пробовал перезагружать контроллер с кнопки и в целом питание по щиту убирать.
Выполнял команду systemctl restart zigbee2mqtt .
Но результата не было.
image

Давайте попробуем последнее, по шагам:

  1. Добавьте в файл конфигурации секцию advanced с настройкой, которая явно отключит аппаратное управление потоком:
advanced:
  rtscts: false
  1. Выключите контроллер кнопкой и включите его заново.
  2. Отпишитесь о результате.

Пришлите также, пожалуйста скриншот настроек модуля расширения: Настройки → Конфигурационные файлы → Модули расширения и порты → Внутренний слот 4.

До факториресет контроллера всё работало хорошо, модуль стоит в самом крайнем слоте? По фото выше трудно судить.

Также будет полезен диагностический архив, создание описано в инструкции.

Приветствую.
*Добавил и с кнопки перезагрузил контроллер. И сервис все равно останавливается.
advanced:
rtscts: false
*Заметил что сервис zigbee2mqtt сперва вроде бы стартует (об этом пишет systemctl status zigbee2mqtt), а потом останавливается.
*Прикрепляю скрины с веб интерфейса:
image
image
Ну и оставлю ошибку:


*Configuration.yml выглядит вот так:

***И вот Логи:
log_20221228T213239.log (17.9 КБ)

1 Like

Спасибо, я посоветуюсь с коллегами и вернусь.

Загрузки? А где тут про node?

Итак, по порядку: какой версии zigbee2mqtt был установлен? В начале темы вижу 1.25.2
Покажите полный вывод при запуске, например как тут: Не запускается zigbe2mqtt
Установите 1.18 для теста.
Ну и проверьте, занят ли чем-то порт.

Вывод с команды: journalctl -u zigbee2mqtt tail -n100
journalctl -u zigbee2mqtt tail -n100.txt (14.7 КБ)
*Zigbee2mqtt стоит 1.25.2

С 1.18 - то же? Ну и какая, кстати версия стояла раньше?

Мы сразу ставили 1.25.2 на большинстве контроллеров все работает

Если есть возможность переставить модуль с другого контроллера - это самый простой, пожалуй способ проверить его.

Информация по занятым портам:
root@wirenboard-ALJE3MX:/mnt/data/root/zigbee2mqtt# ps ax | grep ttyMOD4
12159 pts/0 S+ 0:00 grep ttyMOD4
root@wirenboard-ALJE3MX:/mnt/data/root/zigbee2mqtt# ps ax | grep tty
1226 tty1 Ss+ 0:00 /sbin/agetty --noclear tty1 linux
1229 ttyS0 Ss+ 0:00 /sbin/agetty --keep-baud 115200,38400,9600 ttyS0 vt220
12214 pts/0 S+ 0:00 grep tty

root@wirenboard-ALJE3MX:/mnt/data/etc# lsmod
Module Size Used by
cmac 16384 1
bnep 20480 2
rtl8xxxu 106496 0
mac80211 880640 1 rtl8xxxu
libarc4 16384 1 mac80211
8723bu 897024 0
btusb 49152 0
btrtl 16384 1 btusb
btbcm 16384 1 btusb
btintel 24576 1 btusb
sha256_generic 16384 0
libsha256 20480 1 sha256_generic
bluetooth 397312 26 btrtl,btintel,bnep,btbcm,btusb
cfg80211 741376 3 8723bu,mac80211,rtl8xxxu
ecdh_generic 16384 2 bluetooth
ecc 40960 1 ecdh_generic
rfkill 32768 5 bluetooth,cfg80211
sunxi 20480 0
phy_generic 16384 2 sunxi
musb_hdrc 114688 1 sunxi
udc_core 57344 1 musb_hdrc
w1_gpio 16384 0
wire 40960 1 w1_gpio
ip_tables 24576 0
x_tables 32768 1 ip_tables