Отключение WiFi на WB6.5

Доброй ночи!
У меня контроллер WB 6.5 с интегрированным WiFi? который я брал для развития на будущее.
Подскажите, как отключить точку доступа или как задать пароль для WiFi сети?
На вики нашел только инструкцию по подключению к другой WiFi сети в режиме клиента. В разделе про работу в режиме точки доступа про пароль ни слова

Чтобы установить пароль, необходимо вернуть в /mnt/data/etc/network/interfaces.conf:

# Wireless interfaces

allow-hotplug wlan0
#iface wlan0 inet dhcp
#  wpa-psk A4AA414150
#  wpa-ssid Keenetic-7861

iface wlan0 inet static
  address 192.168.42.1
  netmask 255.255.255.0
  1. Открыть файл mcedit /etc/hostapd.conf:
    Добавить:

     interface=wlan0
     #driver=nl80211
     ssid=WirenBoard-XXXXXXXX
     channel=1
     wpa=2
     wpa_passphrase=fosd1wcB
     wpa_key_mgmt=WPA-PSK
     wpa_pairwise=TKIP CCMP
     rsn_pairwise=TKIP CCMP
    

Понятно, что тут ssid=WirenBoard-XXXXXXXX ваше желаемое название сети, а wpa_passphrase=fosd1wcB ваш желаемый пароль к этому подключению

Евгений, вот еще такая статья вам в помощь: https://wirenboard.com/wiki/index.php/Wirenboard6:InstallingOnTheRemoteSite

А как все-таки отключить wi-fi точку доступа?
В web ui есть возможность снять галку с Auto или Allow hotplug, но это ни к чему не приводит…

1 Like

Так вот же: https://wirenboard.com/wiki/index.php/Wi-Fi#.D0.9D.D0.B0.D1.81.D1.82.D1.80.D0.BE.D0.B9.D0.BA.D0.B0_.D0.B2_.D1.80.D0.B5.D0.B6.D0.B8.D0.BC.D0.B5_.D1.82.D0.BE.D1.87.D0.BA.D0.B8_.D0.B4.D0.BE.D1.81.D1.82.D1.83.D0.BF.D0.B0
Чтобы убрать, нужно, соответственно, отменить эти настройки. Там как раз дальше, где говорится про настройку в режиме клиента, начинается с отмены этих настроек.

1 Like

Добрый день! подскажите, как корректно полностью отключить WiFi модуль?
Куда прописать команду $ hubpower 2:2 power 1 off
чтобы после перезагрузки модуль не поднимался или совсем другой вариант есть?

в /etc/rc.local например

Это в любой версии работает? Мне тоже всё беспроводное обесточить бы.

Подскажите пожалуйста, что именно надо создать и где прописать, что бы hubpower 2:2 power 1 off выполнялось при включении? Вообще, было бы круто выключать Wi-Fi из UI раз и навсегда. Вам явно виднее, но не думаю, что много людей подключаются по вафле)

Здравствуйте! Создайте в папке /etc файл rc.local c флагами разрешения на исполнение (x).
В файл поместите следующий текст (исправлено после сообщения ниже):

#!/bin/bash
# turn off WiFi
hubpower 2:2 power 1 off
logger -s "WiFi was turned off from /etc/rc.local"

Скрипт будет вызываться при запуске системы, отключать WiFi и записывать в лог сообщение “WiFi was turned off from /etc/rc.local”.
Про питание WiFi написано здесь: USB ports power supply — Wiren Board

Поместил файл в /etc , поставил права 777, после перезагрузки всё равно включается Wi-Fi. Изменил hubpower 2:2 power 4 off на hubpower 2:2 power 1 off, всё равно включается(

image

Здравствуйте! Да, спасибо, что поправили, должна работать команда:

hubpower 2:2 power 1 off

Старнно, что у вас не работает. Проверьте сначала так:

hubpower 2:2 status

Затем выполните в командной строке

hubpower 2:2 power 1 off

Проверьте статус и работу WiFi. У меня статус порта 1 изменяется на off и WiFi перестает работать (Wirenboard 6.7.2, версия ядра 5.10.35-wb1). Если вдруг WiFi работает, отключите и остальные порты, выполните:

hubpower 2:2 power 2 off
hubpower 2:2 power 3 off
hubpower 2:2 power 4 off

WiFi должен выключиться. Номер отключенного порта, когда WiFi отключился запишите. Теперь в файл /etc/rc.local записываем работающую команду. Порт с WiFi включите, и выполните в командной строке

/etc/rc.local

Все должно отработать, на экране появятся результаты работы скрипта, WiFi отключится.
Теперь выполните

service rc.local restart

На экране должны появиться результаты работы скрипта без ошибок. Если все нормально попробуйте перезагрузить контроллер. После включения у меня статус порта номер 1 - off, даже если он был включен, WiFi не работает.

Почему вы хотите именно отключать сам порт? Можно просто не конфигурировать WiFi в /etc/network/interfaces (стереть или закомментировать строки, относящиеся к WiFi).

Потому что РЧ железо продолжает работать, а это, в моем случае, внутри стального ящика, наводит на аналоговые входы. Чем меньше лишнего включено, тем лучше. Я б всю вайфайку вообще убрал в опции, мне ни разу не надобилась.

Насколько я понимаю, достаточно отключить точку доступа через /etc/hostapd.conf и/или убрать автоподнятие интерфейса в /etc/network/interfaces. Не обязательно отключать по питанию сам модуль для этого.

Неа. Свистит. Особенно со снятой антенной (нетерминированный выход). А она мешает обычно.

то есть после

systemctl hostapd stop
ifconfig wlan0 down
ifconfig wlan1 down

наводки есть, а после hubpower - пропадают?

Это очень-очень странно, проверьте пожалуйста ещё раз.

Сорян, не сейчас. Я несу горящий веник из соседней темы.

Сама по себе эта команда работает, но вот при включении порт всё равно активен. При запуске из командной строки вот что вылезает:

root@wirenboard-A2T6NRMB:~# sh /etc/rc.local
Invalid port power level: off
)<13>Jul  8 14:39:41 root: WiFi was turned off from /etc/rc.local

Содержимое rc.local:

#!/bin/bash
# turn off WiFi
hubpower 2:2 power 1 off
logger -s "WiFi was turned off from /etc/rc.local"

Invalid port power level: off

Это означает неверный аргумент “off”

Покажите, пожалуйста, вывод команд по отдельности:

hubpower
hubpower 2:2 status
hubpower 2:2 power 1 off
root@wirenboard-A2T6NRMB:~# hubpower
Usage:  hubpower busnum:devnum power {portnum (on|off)} ...
        hubpower busnum:devnum status
        hubpower busnum:devnum bind
root@wirenboard-A2T6NRMB:~# hubpower 2:2 status
Port  1 status: 0503  High-Speed Power-On Enabled Connected
Port  2 status: 0100  Power-On
Port  3 status: 0100  Power-On
Port  4 status: 0100  Power-On
root@wirenboard-A2T6NRMB:~# hubpower 2:2 power 1 off
Port  1 status: 0000  Power-Off