подключения счётчика Милур 105

Здравствуйте! как правильно прописывать адрес счётчика? либо 3 последние цифры заводского номера, либо номер 255? затем нужно ли прописывать пароль? также куда подключать клемы rs-485? есть плюс и минус на интерфейсных клемах, куда A и B?

Добрый день!

  1. Напишите про свои страдания пожалуйста на info@milur.ru , может быть им наконец надоест и они сделают нормальный мануал, который не противоречит сам себе в пяти местах.

  2. В тех, которые я видел, заводской адрес был 255. Можно нажимать что-то на счётчике пока на экране не появится адрес, подписан по-моему П1. В шестнадцатеричном формате. Т.е. если увидели FF, то всё ок - у вас адрес 255.

  3. пароль дефолтный менять не нужно, если счётчик новый

  4. плюс к A, минус к B. Только два провода, питание на интерфейс подавать не нужно!

  5. Если так и не заработает, то возможно вам достался счётчик, в котором производители вдруг решили отключить (sic) доступ по однобайтовому адресу. Тогда вам нужно либо ждать, когда мы наконец прикрутим доступ по серийнику, или воспользоваться нехитрой процедурой из десяти несложных шагов, чтобы с помощью специальной программы активировать режим обратно.
    За подробностями можете написать нам на support@, а лучше на info@milur.ru, желательно не стесняясь в выражениях (см. п.1)

1 Like

я подключил счётчик ко второму порту rs-485, но изначально ввёл адрес
как было написано 3 последние цифры заводского номера. Теперь не могу ни
удалить, ни изменить адрес. из конфигурационного файла счётчик удаляется
и добавляется. а вот в веб интерфейсе ничего не
происходит. как был счётчик с адресом 469, так и остаётся.
команда
mqtt-delete-retained ‘/devices/Milur_105_469/#’
ничего не делает.
и ещё я подключил питания на клемы 12 вольт. их обязательно нужно
отключить или это не влияет?

да, так и должно быть, пока вы явно не вычистите топики

А откуда вы взяли “Milur_105_469”? Вам нужно пойти в Settings и посмотреть название топика (регистр важен!), а не пытаться его придумать

Я бы для начала отключил

а как вычищать информацию если не этим способом? названия я взял именно так как написано в devices Milur 105 469. и ещё когда поставил адрес 255 все устройства на rs-485 перестали работать. точнее получать и передавать команды.

читайте пожалуйста, что я написал. У вас большая буква M, её точно не могло быть в названии топика. Вы вместо того, чтобы скопировать кусок топика из Settings как я прошу, либо набрали его вручную с ошибкой, либо скопировали что-то не то и не оттуда.

Это не баг репорт. Не написано ,что за устройства подключены, куда вы его поставили, как вы поняли, что перестали получать и передавать команды.

Могу предположить, что вы подключили на одну линию с милурами ещё что-то. Пожалуйста хотя бы на время тестов оставьте только ОДНО устройство на шине и в настройках - ваш счётчик.

Ещё пожалуйста проверьте, что у вас в настройках порта в веб-интерфейсе стоит скорость 9600, parity - none, stop bits - 1 (а не 2).

Евгений, я скопировал именно так как написано в разделе devices именно первая буква M большая, хотя я пробовал удалять топики и писать milur_105_469 и MILUR_105_469 и Milur 105_469 вообщем разные конфигурации, но ничего не происходит. предполагаю, что устройства перестают работать потому что в системе появляется 2 прибора с адресом 255, потому что я их создавал 2 раза, затем удалял и снова создавал. кстати если создать счётчик с заводским адресом то тоже на первом порту перестают реагировать устройства, после удаления милура из конфигурационного файла всё начинает работать опять в нормальном режиме. счётчик у меня висит на втором порту rs-485 один, больше там ничего нет. все настройки такие как вы и написали. стоповый бит я поставил единицу. для начала мне нужно вычистить топики, но как не могу понять.

нужно сделать, как я писал:

нет, это совершенно никак не влияет на нормальную работу. Ну висит у вас лишний девайс в Device и чёрт с ним.

я не знаю такого понятия. Что именно и куда вы вписали?

"создать счётчик с заводским адресом означает, что в поле адрес вписывается 3 последние цифры заводского номера счётчика. всё, в топиках сделал очистку с именем milur105_469. правда в веб интерфейсе всё-равно болтаются пустые значения, но они должны вроде как-то потом очиститься?

да, по f5

Не могу разобраться в чём проблема??? при добавлении устройства на порт Port /dev/ttyAPP4, перестают работать устройства на Port /dev/ttyAPP1! причём добавляю счётчик с адресом 255 или 469, сразу перестают работать другие устройства на первом порту. удаляю - всё начинает работать в нормальном режиме. на порту Port /dev/ttyAPP4 ничего кроме милур 105 не висит. на Port /dev/ttyAPP1 приборы только вашего производства. что делать???

Выложите сюда или пришлите на support@ файл /etc/wb-mqtt-serial.conf и вывод

cat /var/log/messages | grep serial | tail -n 200

Отлично, получил файл. Милуров в конфиге нет, Modbus девайсы отлично работают. Куда смотреть?

незнаю, что произошло, но вот сейчас создал устройство milur105 с адресом 255 и всё заработало, почему не работало до этого так и не понял, но самое главное, что сейчас работает!!! Спасибо!

Аналогичная ситуация прям слово в слово. Только WB4. Пока сколько ни мучил, ничего не заработало.
Мало того, в Devices Веб-панели не появляется ничего нового. Естественно, все настройки порта сделал как написано в данном топике. Что делать? Если скажете, лог пришлю.

С большой вероятность, у вас не “аналогичная проблема”, а что-то совершенно не связанное. Пишите нормальный подробный баг-репорт. Если у вас нет счётчика Милур 105 - то в отдельную тему, эта тут не при чём.

У меня именно Милур 105. Сейчас сделаю баг-репорт.

Это уже интереснее. Тогда да, жду. Приложите пожалуйста конфиг /etc/wb-mqtt-serial.conf целиком (его можно из веб-интерфейса по кнопке JSON утащить)