Проблемы с модулем WBIO-AO-10V-8


#1

Здравствуйте. После добавления модуля WBIO-AO-10V-8 в разделе Hardware Modules Configuration в файле wb-mqtt-dac.conf возникает ошибка. в веб интерфейсе его невозможно прочитать. Сам модуль работает. Но после перезагрузки перестает реагировать. При удалении устройства из Hardware Modules Configuration файл wb-mqtt-dac.conf вновь становится доступным. При этом в самом контроллере я нашел два файла wb-mqtt-dac.conf . Один по пути /etc/ и его содержимое соответствует пустому шаблону ( в приложении 1wb-mqtt-dac) . Второй файл в находится в mnt/data/etc и при этом его содержимое соответствует ситуации, когда модуль добавлен в список Hardware Modules Configuration (в приложении wb-mqtt-dac), то есть до удаления. Вопросы:

  1. как восстановить работоспособность?
  2. при изучении работы модуля понятие "перезагрузить " воспринималось мной, как нажатие на кнопку питания контроллера и последующее включение, что приводило к сбою конфигурации и пропаже устройств. Сейчас после каждого изменения я выполняю команду REBOOT . все модули спокойно удаляются и добавляются. Кроме WBIO-AO-10V-8 . У него проблема с файлами. отключение питания у контроллера равносильно команде REBOOT?
  3. чем вызвана разница в файлах wb-mqtt-dac.conf. На изменения конфигурации реагирует фалу по пути /etc/ . другой остается неизменным

В приложении так же высылаю файл messages.
1wb-mqtt-dac.conf (56 Байты)
wb-mqtt-dac.conf (1.3 КБ)
messages.txt (771.0 КБ)


#2

У вас перед WBIO-AO-10V-8 какие-либо еще модули стоят?


#3

Дмитрий, воспроизвели проблему у себя, разбираемся.


#4

Да . проще сфотографировать.


Модуль цап в конце. еще вопрос. у вас есть бэкап с дефолтными файлами? реально ли откатится до состояния , как после покупки? насколько я понял сброс к заводским настройкам файлы не заменит.


#5

У вас только WBIO-AO-10V-8 отваливается после перезагрузки?
Остальные (в частности WBIO-DO-R10A-8) остаются?


#6

Да. Именно так. причем после как после REBOOT, так и после аппаратной перезагрузки. Остальные модули стабильно работают


#7

В моем случае отваливается WBIO-DO-R10A-8, стоящий после WBIO-AI-DV-12.
Попробуйте убрать WBIO-AI-DV-12 и сделать перезагрузку.


#8

Скажите, ваш модуль RS485 WB-MIO поддерживает модули ЦАП WBIO-AO-10V-8 ? в списке устройств при конфигурации rs-485 его нет. но нам однажды понадобилось вывести модули АЦП в сеть rs-485 и техподдержка выслала файл для конфигурации в сети rs485 . в списке стандартных устройств его тоже не было. имеется ли нечто подобное у вас для модуля ЦАП WBIO-AO-10V-8?


#9

Ошибка повторяется даже тогда , когда модуль WBIO-AO-10V-8 подключен один к шине. Может ли это быть проблема в самом модуле? после нескольких перезагрузок он может заработать вновь, но после следующей перезагрузки вновь отвалится


#10

Имеет ли смысл в моем случае производить сброс к заводским настройкам?


#11

К сожалению, нет. У нас написано “В настоящее время не работает с преобразователем интерфейсов WB-MIO”, но и в дальнейшем разрабатывать поддержку не планируется.


#12

Нет, не поможет. Это похоже на баг. Разработчики в курсе проблемы, разбираемся.


#13

Скажите пожалуйста, существуют ли консольные команды через которые я в явном виде смогу понять отвечает ли устройство или нет?


#14

Дмитрий, с боковыми модулями сложнее, чем с Modbus-устройствами.
Командой i2cdetect -y 1 можно проверить физическое подключение модулей к контроллеру. А явной команды для проверки нет.


#15


После команды i2cdetect -y 1 вышло сообщение (см. скриншот выше). как его расшифровывать?
на момент выхода этого сообщения абсолютно все модули работали.


#16

Эта команда показывает, какие устройства подключены к боковой i2c-шине. К сожалению, информация может отображаться некорректно,если устройства настроены в wb-hardware.conf.
Вы можете убрать из конфигурации все устройства, отсоединить боковые модули, затем подключать их по по одному, и смотреть, какие адреса получают подключаемые модули и видятся ли они.
С багом разбираемся.


#17

Здравствуйте. Есть ли какие-нибудь новости по поводу бага?


#18

Дмитрий, добрый день! Пока нет, к сожалению, разработчики исследуют проблему.


#19

Здравствуйте. Дело в том, что у нас совсем не остается времени ждать. Проект фактически приостановился. Есть ли возможность заменить модуль аналоговых выходов WBIO-AO-10V-8 на модуль WBIO-DI-DR-16?


назначил(а) ответственного EvgenyBoger #20