После обновления не могу зайти в web-ui

Добрый день, вот такой возник вопрос, обновил прошивку вб до крайней версии, обновлял через вем морду. обновление прошло, установил нужные пакеты, node-red и zigbee2mqtt в веб интерфейс заходит, а в веб интерфейс самого вб не хочет входить ни в какую , ssh тоже работает, подскажите куда смотреть может какие тесты провести?

1 Like

Добрый день.
Пришлите диагностический архив. Он может помочь понять причину.

Добрый день.
Подскажите, ваша проблема актуальна?

Аналогичная проблема возникла. пишет не удалось получить доступ к сайту. пробовал через несколько устройств но безуспешно. Node red работает нормально. у меня проблема пока что актуальна

приложен диагностический архив, доступен только сотрудникам поддержки
(115,7 КБ)

Oct 01 14:22:01 wirenboard-ACATBBJK nginx[2782]: nginx: [emerg] unknown directive "upload_pass" in /etc/nginx/sites-enabled/default:48
Oct 01 14:22:01 wirenboard-ACATBBJK nginx[2782]: nginx: configuration file /etc/nginx/nginx.conf test failed

При этом:

ii  nginx-common                          1.18.0-6.1+deb11u3                     all          small, powerful, scalable web/proxy server - common files
ii  nginx-extras                          1.18.0-6.1+deb11u3                     armhf        nginx web/proxy server (extended version)

А покажите пожалуйста конфиг /etc/nginx/sites-enabled/default

default (2,1 КБ)

Замените содержимое на

# You may add here your
# server {
#	...
# }
# statements for each of your virtual hosts to this file

##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

upload_progress fwupdate 1M;

server {
	#listen   80; ## listen for ipv4; this line is default and implied
	#listen   [::]:80 default_server ipv6only=on; ## listen for ipv6

	root /var/www;

	# Make site accessible from http://localhost/
	server_name localhost;

	location / {
		index index.html;
		try_files $uri $uri/ /index.html;
		add_header Cache-Control "no-store, no-cache, must-revalidate";
	}

	location ~* \.(js|jpg|jpeg|gif|png|svg|css)$ {
		add_header Cache-Control "max-age=31536000";
	}

    location /fwupdate/download/rootfs {

        limit_except GET {
            deny all;
        }

        fastcgi_param SCRIPT_FILENAME /usr/lib/cgi-bin/download_rootfs.sh;
        fastcgi_param SCRIPT_NAME download_rootfs.sh;
        fastcgi_param QUERY_STRING $query_string;
        fastcgi_param REQUEST_METHOD $request_method;
        fastcgi_param CONTENT_TYPE $content_type;
        fastcgi_param CONTENT_LENGTH $content_length;
        fastcgi_param REQUEST_URI $request_uri;
        fastcgi_pass unix:/var/run/fcgiwrap.socket;
        fastcgi_request_buffering off;  # to allow stream-downloading via backend

    }

	location /fwupdate/upload {
		limit_except POST {
			deny all;
		}
		client_body_buffer_size 128K;
		client_max_body_size 1000M;

		gzip off;

		fastcgi_param UPLOADS_DIR /var/www/uploads;
		fastcgi_param SCRIPT_FILENAME /usr/lib/cgi-bin/fwupdate_upload.py;
		fastcgi_param SCRIPT_NAME fwupdate_upload.py;
		fastcgi_param QUERY_STRING $query_string;
		fastcgi_param REQUEST_METHOD $request_method;
		fastcgi_param CONTENT_TYPE $content_type;
		fastcgi_param CONTENT_LENGTH $content_length;
		fastcgi_param REQUEST_URI $request_uri;
		fastcgi_pass unix:/var/run/fcgiwrap.socket;
		fastcgi_request_buffering off;  # to allow stream-downloading via backend

		track_uploads fwupdate 5s;
	}

	location /fwupdate/progress {
		report_uploads fwupdate;
	}

	location /mqtt {
	    proxy_pass http://localhost:18883;
	    proxy_http_version 1.1;
	    proxy_set_header Upgrade $http_upgrade;
	    proxy_set_header Connection upgrade;
	}
}

Предполагаю что ранее был отредактирован а при обновлении вы выбрали “оставить без изменения”.

после обновления кстати говоря работал. я еще устройства rs485 добавлял. а потом почему то перестал заходить. и я забил. а сейчас необходимость возникла решил решить.

благодарю все заработало!!!

Эта тема была автоматически закрыта через 7 дней после последнего ответа. В ней больше нельзя отвечать.