Постоянные перезагрузки WB-MAI11

Здравствуйте!

Используем WB-MAI11 для снятия показаний с 11-ти температурных датчиков и двух манометров. Датчики температуры подключены по двухпроводной схеме ко входам IN1P/IN1N…IN5P/IN5N,IN6P, а манометры в режиме измерения тока 4-20 мА подключены ко входам IN7P/IN7N. Напряжение на входе MAI11 стабильное, в районе 13,5 В и приходит напрямую от источника питания. При этом MAI11 постоянно перезагружается. Интервал перезагрузки меняется он нескольких секунд до, редко, почти часа. Пробовал отключать опрос как 1-6 входов (термостатов), так и 7-го входа (измерение тока 4-20 мА). Даже физически отключал входы 1-6. Всё равно MAI11 перезагружается.
Немного смущает плавающее на выходах 5 В напряжение от 5,2 В до 4,7 В (при этом, по входу проседания нет, мощности блока питания тоже с избытком).

Что бы это могло быть, и как с этим бороться?

Прилагаю графики показаний. Входное напряжение снимаю с соседнего WB-MS v.2.


        {
          "channels" : 
          [
            {
              "channels" : 
              [
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_P"
                },
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_N"
                }
              ],
              "device_type" : "p_2w_50m",
              "name" : "Input 1"
            },
            {
              "channels" : 
              [
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_P"
                },
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_N"
                }
              ],
              "device_type" : "p_2w_50m",
              "name" : "Input 2"
            },
            {
              "channels" : 
              [
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_P"
                },
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_N"
                }
              ],
              "device_type" : "p_2w_50m",
              "name" : "Input 3"
            },
            {
              "channels" : 
              [
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_P"
                },
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_N"
                }
              ],
              "device_type" : "p_2w_50m",
              "name" : "Input 4"
            },
            {
              "channels" : 
              [
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_P"
                },
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_N"
                }
              ],
              "device_type" : "p_2w_50m",
              "name" : "Input 5"
            },
            {
              "channels" : 
              [
                {
                  "data_rate" : 20,
                  "device_type" : "2w_50m",
                  "name" : "IN_P"
                },
                {
                  "device_type" : "disabled",
                  "name" : "IN_N"
                }
              ],
              "device_type" : "p_2w_50m",
              "name" : "Input 6"
            },
            {
              "channels" : 
              [
                {
                  "data_rate" : 20,
                  "device_type" : "4_20ma",
                  "max" : 4000,
                  "min" : 0,
                  "name" : "IN_P"
                },
                {
                  "data_rate" : 20,
                  "device_type" : "4_20ma",
                  "max" : 4000,
                  "min" : 0,
                  "name" : "IN_N"
                }
              ],
              "device_type" : "p_4_20ma",
              "name" : "Input 7"
            },
            {
              "device_type" : "disabled",
              "name" : "Input 8"
            },
            {
              "device_type" : "disabled",
              "name" : "Input 9"
            },
            {
              "device_type" : "disabled",
              "name" : "Input 10"
            },
            {
              "device_type" : "disabled",
              "name" : "Input 11"
            }
          ],
          "device_type" : "WB-MAI11",
          "read_rate_limit_ms" : 10000,
          "slave_id" : "28"
        }

Очень похоже на ошибку:

ERRMAI110006: Некорректная работа защиты при коротком замыкании линии 5V

Подверженные устройства

Все WB-MAI11

Описание

Из-за ошибки в схеме защиты, при коротком замыкании линий 5V и iGND происходит просадка напряжения на внутренней линии 5В, что может привсти к перезагрузке устройства.

Проверьте подключения

Видели эту ошибку в Errata, но ничего не нашли. Попробуем для чистоты эксперимента отключить физически все колодки с датчиками и проверим, будет ли перезагружаться. Если перестанет — попробуем найти из-за какого именно входа такое происходит. Отпишусь по результату.

1 Like

Отключение внешних датчиков не помогло. Устройство всё так же за 15 минут перезагрузилось несколько раз. Опрос в настройках был оставлен, как и раньше, просто все показания покраснели. Видимо, всё таки проблема не в возможном КЗ какого-либо из датчиков, а в самом MAI11. Скрин с версией прошивки и серийником прилагаю.

Добрый день.
Какая версия прошивки в MAI6?
Tесли 2.0.0 - обновите, есть 2.0.1

У нас не MAI6, а ещё MAI11, и для неё, как я вижу, прошивка 1.3.1 является последней.

Здравствуйте! Такое поведение модуля было сразу после покупки? При перезагрузке гаснет зеленый светодиод статуса, а потом загорается опять?
Есть возможность проверить работу модуля при питании 24 В?
Попробую воспроизвести проблему.

Пока попробовали проверить другим путём. Поставили второй (новый из коробки) MAI11 вместо этого перезагружающегося, ничего не меняя, воткнув те же колодки на те же места в новый MAI, просто променяв в конфиге контроллера адрес устройства. Прошивка была старая, обновил её до последней, чтобы всё было единообразно. Пока работает, уже почти полчаса. Завтра сообщу, были ли перезагрузки.

А с этим хотелось бы разобраться, аппаратная ли это проблема, или нет. Может, можно как-то принудительно стереть в нём все настройки, может что-то от прошлых конфигураций осталось? Подключу его просто к питанию и modbus’у и буду опрашивать uptime, без настройки каких-либо датчиков.

К сожалению, были ли раньше перезагрузки не скажу, немного потестировали его до этого и убрали, может, он тогда тоже перезагружался. Сейчас просто начали плотно использовать, и стало заметно.

Прошлые настройки не должны влиять на перезагрузки модуля.

Если будет просто лежать на столе с отключенными разъемами (кроме питания и шины RS485), питание будет в норме и при этом модуль будет перезагружаться (сбрасываться время работы в регистрах, гаснуть зеленый светодиод статуса), то это явно не нормально и будет гарантийным случаем.
Проверьте питание еще мультиметром.

Для надёжности всё таки перепрошил модуль со сбросом всех настроек (оказалось, что он и адрес на 1-й сбрасывает, восстановил потом 28-й как на наклейке). Но это не помогло, всё так же перезагружается через какое-то (случайное) время.

Заметил, что в перезагрузку уходит обычно во время опроса. Частота у меня 10 секунд, и именно во время обмена данными он отваливается, и лампочка на какое-то время гаснет.

Напряжение подавал уже с другого источника, мультиметром измерял — стабильно 11,95 В, даже в момент перезагрузки.

А тот сменный модуль, который мы поставили на опрос датчиков, стабильно работает без перезагрузок. У этого же график аптайма всё такой же — пила.

Давайте мы бесплатно поменяем вам оборудование. Курьер привезёт новое оборудование и заберёт старое:

  • модуль WB-MAI11 (1 шт.)

Для возврата напишите, пожалуйста, письмо на info@wirenboard.com.

В письме укажите:

  1. ссылку на эту тему,
  2. серийный номер устройства, если есть,
  3. ваш действующий телефон, адрес доставки, ФИО получателя.

Спасибо, обязательно свяжемся с вами по указанному адресу!