WB-MGE+WB-M1W2 как проверить проходит сигнал с датчика или нет?

Добрый день!
Я приобрел два устройства (WB-MGE и WB-1M2W) и датчик температуры.
Собрал схему и подключил к компьютеру, подскажите как мне теперь проверить работает ли всё это или нет.
Я в этих устройствах новичок.

Добрый день!

На компьютере используйте, например, Modbus Poll.
Протокол подключения - Modbus RTU Over TCP.
Настройте скорость порта Serial на WB-MGE 9600 8N2: https://wirenboard.com/wiki/index.php?title=WB-MIO-E_and_WB-MGE_Ethernet_Connection_Setup
Потом опросите, например, одиночный регистр 0x80 - там должен лежать адрес устройства. Потом уже опрашивайте значения с датчика: https://wirenboard.com/wiki/index.php/WB-M1W2_1-Wire_to_Modbus_Temperature_Measurement_Module#.D0.9A.D0.B0.D1.80.D1.82.D1.8B_.D1.80.D0.B5.D0.B3.D0.B8.D1.81.D1.82.D1.80.D0.BE.D0.B2

Как это сделать?

С помощью программы


Что я делаю не так?

Прошу прощения, что не указал в первом посте что модули подключены по изернет через роутер.
Во всех статьях и видео подключают по USB.

  1. Пришлите, пожалуйста, скриншот браузера с настройками Serial на WB-MGE.
  2. Фотографию вашего WB-M1W2.
  3. В Modbus Poll в настройка чтения поставьте Address: 128 и Quantity: 1.

Не помогло, тайм аут эрор.

  1. Последняя картинка наполовину белая.
  2. Фото с WB-M1W2 мне нужно с наклейкой с адресом.
  3. Давайте ещё фото подключения целиком, чтобы все провода и соединения было видно.
  4. Скриншот из Modbus Poll снова.

Вы что-то странное делаете.
Slave ID (адрес устройства): 142 (не 124!)
Address (номер регистра): 128 (не 0!)


Спасибо за помощь.

Я сразу написал что тема для меня новая.

Устал, глаза в кучу.

1 Симпатия


Кажется у меня вышло из строя устройство, вчера демонстрировал начальнику и вдруг Timeout error.
Сможете подсказать что могло случится?

До этого что-то с устройством делали?

Только отсоединял питание.
Мультиметром проверял, питание есть.
На выходах RS-485 2.2V, в документации указано 3,3V.

WB-MGE по IP-адресу доступен?

Да, доступен. В веб интерфейс захожу без проблем. Другие программы для работы с мадбас видят подключение, но регистры не опрашиваются. Я потому и решил что WB-1M2W вышел из строя.

Странно, конечно. Можете прислать нам, но если проблема не подтвердится, возьмём немного денег за проверку. Если решите сделать так, напишите, пожалуйста, на info@contactless.ru со ссылкой на этот комментарий.